Skip to content

← Actionable
Critical, CVSS 9.8amended

Unstructured has Path Traversal via Malicious MSG Attachment that Allows Arbitrary File Write

CVE-2025-64712GHSA-gm8q-m8mv-jj5m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (unstructured 0.18.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-64712: 0.69% estimated exploitation activity in the next 30 days; percentile 52.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Path Traversal vulnerability in the partitionmsg function allows an attacker to write or overwrite arbitrary files on the filesystem when processing malicious MSG files with attachments.

Impact An attacker can craft a malicious .msg file with attachment filenames containing path traversal sequences (e.g., ../../../etc/cron.d/malicious). When processed with processattachments=True, the library writes the attachment to an attacker-controlled path, potentially leading to: - Arbitrary file overwrite - Remote code execution (via overwriting configuration files, cron jobs, or Python packages) - Data corruption - Denial of service

Affected Functionality The vulnerability affects the MSG file partitioning functionality when processattachments=True is enabled.

Vulnerability Details The library does not sanitize attachment filenames in MSG files before using them in file write operations, allowing directory traversal sequences to escape the intended output directory.

Workarounds…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gm8q-m8mv-jj5m

  2. Revision 2 · amended ·

    Amended from osv record GHSA-gm8q-m8mv-jj5m

  3. Revision 1 · created ·

    Published from ghsa record GHSA-gm8q-m8mv-jj5m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64712

Advisory: Unstructured has Path Traversal via Malicious MSG Attachment that Allows Arbitrary File Write
IDs: CVE-2025-64712, GHSA-gm8q-m8mv-jj5m
Record: https://patchnext.com/advisories/cve-2025-64712 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: unstructured 0.18.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI unstructured: affected <= 0.18.17; fixed in 0.18.18

## Suggested inspection (read-only)
- `python -m pip show unstructured`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on unstructured.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gm8q-m8mv-jj5m (GitHub-reviewed advisory GHSA-gm8q-m8mv-jj5m lists affected ranges: PyPI unstructured >=0 <=0.18.17)
- Verified: https://osv.dev/vulnerability/GHSA-gm8q-m8mv-jj5m (OSV record GHSA-gm8q-m8mv-jj5m lists affected ranges: PyPI unstructured >=0 <0.18.18 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…