Mattermost doesn't verify that post actions invoking /share-issue-publicly were created by the Jira plugin
CVE-2025-64641GHSA-vww6-79rv-3j4x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.0.0-20251121122154-b57c297c6d7; github.com/mattermost/mattermost-server 11.1.1, 11.0.6, 10.12.4, 10.11.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- < 8.0.0-20251121122154-b57c297c6d7
- Fixed in
- 8.0.0-20251121122154-b57c297c6d7
Go github.com/mattermost/mattermost-server
- Affected
- >= 10.11.0, < 10.11.8>= 10.12.0, < 10.12.4>= 11.0.0, < 11.0.6>= 11.1.0, < 11.1.1
- Fixed in
- 10.11.8, 10.12.4, 11.0.6, 11.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vww6-79rv-3j4x lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =10.11.0 =10.12.0 =11.0.0 =11.1.0 <11.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N
- EPSS
- CVE-2025-64641: 0.18% estimated exploitation activity in the next 30 days; percentile 6.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 11.1.x <= 11.1.0, 11.0.x <= 11.0.5, 10.12.x <= 10.12.3, 10.11.x <= 10.11.7 fail to verify that post actions invoking /share-issue-publicly were created by the Jira plugin which allowed a malicious Mattermost user to exfiltrate Jira tickets when victim users interacted with affected posts
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vww6-79rv-3j4x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64641 Advisory: Mattermost doesn't verify that post actions invoking `/share-issue-publicly` were created by the Jira plugin IDs: CVE-2025-64641, GHSA-vww6-79rv-3j4x Record: https://patchnext.com/advisories/cve-2025-64641 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20251121122154-b57c297c6d7; github.com/mattermost/mattermost-server 11.1.1, 11.0.6, 10.12.4, 10.11.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20251121122154-b57c297c6d7; fixed in 8.0.0-20251121122154-b57c297c6d7 - Go github.com/mattermost/mattermost-server: affected >= 10.11.0, < 10.11.8; >= 10.12.0, < 10.12.4; >= 11.0.0, < 11.0.6; >= 11.1.0, < 11.1.1; fixed in 10.11.8, 10.12.4, 11.0.6, 11.1.1 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vww6-79rv-3j4x (GitHub-reviewed advisory GHSA-vww6-79rv-3j4x lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =10.11.0 =10.12.0 =11.0.0 =11.1.0 <11.1.1) Commands are suggestions: review each one before running it.
Loading voting…