Strapi has a rate limit bypass on users-permissions plugin via attacker-controlled email keying
CVE-2025-64526GHSA-7mqx-wwh4-f9fw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/plugin-users-permissions 5.45.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @strapi/plugin-users-permissions
- Affected
- <= 5.44.0
- Fixed in
- 5.45.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7mqx-wwh4-f9fw lists affected ranges: npm @strapi/plugin-users-permissions >=0 <5.45.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mqx-wwh4-f9fw lists affected ranges: npm @strapi/plugin-users-permissions >=0 <=5.44.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-64526: 0.49% estimated exploitation activity in the next 30 days; percentile 42.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary of CVE-2025-64526 Vulnerability Details - CVE: CVE-2025-64526 - CVSS v3.1 Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N (6.9 — Medium) - Affected Versions: @strapi/plugin-users-permissions <=5.44.0 - How to Patch: Immediately update your Strapi to =5.45.0 Description of CVE-2025-64526 In Strapi versions prior to 5.45.0, the rate-limit middleware in the users-permissions plugin derived its rate-limit key in part from ctx.request.body.email, including on routes whose body schema does not contain an email field (/auth/local, /auth/reset-password, /auth/change-password). An unauthenticated attacker could include an arbitrary email value in the request body to obtain a fresh rate-limit key per request, effectively bypassing per-IP throttling on those routes and enabling high-volume credential brute-force, password-reset code brute-force, and credential-stuffing attempts. The rate-limit key was constructed as…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7mqx-wwh4-f9fw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7mqx-wwh4-f9fw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64526 Advisory: Strapi has a rate limit bypass on users-permissions plugin via attacker-controlled email keying IDs: CVE-2025-64526, GHSA-7mqx-wwh4-f9fw Record: https://patchnext.com/advisories/cve-2025-64526 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @strapi/plugin-users-permissions 5.45.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @strapi/plugin-users-permissions: affected <= 5.44.0; fixed in 5.45.0 ## Suggested inspection (read-only) - `npm ls @strapi/plugin-users-permissions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @strapi/plugin-users-permissions. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7mqx-wwh4-f9fw (OSV record GHSA-7mqx-wwh4-f9fw lists affected ranges: npm @strapi/plugin-users-permissions >=0 <5.45.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7mqx-wwh4-f9fw (GitHub-reviewed advisory GHSA-7mqx-wwh4-f9fw lists affected ranges: npm @strapi/plugin-users-permissions >=0 <=5.44.0) Commands are suggestions: review each one before running it.
Loading voting…