PYSEC-2025-237
CVE-2025-64521GHSA-xr73-jq5p-ch8r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (authentik-client 2025.10.2, 2025.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI authentik-client
- Affected
- >= 2025.8.0, < 2025.8.5>= 2025.10.0, < 2025.10.2
- Fixed in
- 2025.8.5, 2025.10.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2025-237 lists affected ranges: PyPI authentik-client >=2025.8.0 =2025.10.0 <2025.10.2 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2025-64521: 0.23% estimated exploitation activity in the next 30 days; percentile 14.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
authentik is an open-source Identity Provider. Prior to versions 2025.8.5 and 2025.10.2, when authenticating with client_id and client_secret to an OAuth provider, authentik creates a service account for the provider. In previous authentik versions, authentication for this account was possible even when the account was deactivated. Other permissions are correctly applied and federation with other providers still take assigned policies correctly into account. authentik versions 2025.8.5 and 2025.10.2 fix this issue. A workaround involves adding a policy to the application that explicitly checks if the service account is still valid, and deny access if not.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record PYSEC-2025-237
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64521 Advisory: PYSEC-2025-237 IDs: CVE-2025-64521, GHSA-xr73-jq5p-ch8r Record: https://patchnext.com/advisories/cve-2025-64521 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: authentik-client 2025.10.2, 2025.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI authentik-client: affected >= 2025.8.0, < 2025.8.5; >= 2025.10.0, < 2025.10.2; fixed in 2025.8.5, 2025.10.2 ## Suggested inspection (read-only) - `python -m pip show authentik-client`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on authentik-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2025-237 (OSV record PYSEC-2025-237 lists affected ranges: PyPI authentik-client >=2025.8.0 =2025.10.0 <2025.10.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…