sudo-rs doesn't record authenticating user properly in timestamp
CVE-2025-64517GHSA-q428-6v73-fc4q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sudo-rs 0.2.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io sudo-rs
- Affected
- >= 0.2.5, < 0.2.10
- Fixed in
- 0.2.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q428-6v73-fc4q lists affected ranges: crates.io sudo-rs >=0.2.5 <0.2.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.4 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2025-64517: 0.18% estimated exploitation activity in the next 30 days; percentile 7.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When Defaults targetpw (or Defaults rootpw) is enabled, the password of the target account (or root account) instead of the invoking user is used for authentication. sudo-rs prior to 0.2.10 incorrectly recorded the invoking user’s UID instead of the authenticated-as user's UID in the authentication timestamp. Any later sudo invocation on the same terminal while the timestamp was still valid would use that timestamp, potentially bypassing new authentication even if the policy would have required it. Impact A highly-privileged user (able to run commands as other users, or as root, through sudo) who knows one password of an account they are allowed to run commands as, would be able to run commands as any other account the policy permits them to run commands for, even if they don't know the password for those accounts. A common instance of this would be that a user can still use their own password to run commands as root (the default behaviour of sudo), effectively negating the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q428-6v73-fc4q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64517 Advisory: sudo-rs doesn't record authenticating user properly in timestamp IDs: CVE-2025-64517, GHSA-q428-6v73-fc4q Record: https://patchnext.com/advisories/cve-2025-64517 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sudo-rs 0.2.10. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io sudo-rs: affected >= 0.2.5, < 0.2.10; fixed in 0.2.10 ## Suggested inspection (read-only) - crates.io sudo-rs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sudo-rs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q428-6v73-fc4q (GitHub-reviewed advisory GHSA-q428-6v73-fc4q lists affected ranges: crates.io sudo-rs >=0.2.5 <0.2.10) Commands are suggestions: review each one before running it.
Loading voting…