Skip to content

← Actionable
Critical, CVSS 9.3

Milvus Proxy has a Critical Authentication Bypass Vulnerability

CVE-2025-64513GHSA-mhjq-8c7m-3f7p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/milvus-io/milvus 2.6.5, 2.5.21, 2.4.24, 0.10.3-0.20251107071934-6102f001a971), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/milvus-io/milvus

    Affected
    >= 0.10.4, < 2.4.24>= 2.5.0, < 2.5.21>= 2.6.0, < 2.6.5< 0.10.3-0.20251107071934-6102f001a971
    Fixed in
    0.10.3-0.20251107071934-6102f001a971, 2.5.21, 2.6.5, 2.4.24

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-mhjq-8c7m-3f7p lists affected ranges: Go github.com/milvus-io/milvus >=0.10.4 =2.5.0 =2.6.0 =0 <0.10.3-0.20251107071934-6102f001a971

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-64513: 0.87% estimated exploitation activity in the next 30 days; percentile 58.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? An unauthenticated attacker can exploit this vulnerability to bypass all authentication mechanisms in the Milvus Proxy component, gaining full administrative access to the Milvus cluster. This grants the attacker the ability to read, modify, or delete data, and to perform privileged administrative operations such as database or collection management. All users running affected Milvus versions are strongly advised to upgrade immediately. Patches Has the problem been patched? What versions should users upgrade to? This issue has been fixed in the following versions: • Milvus 2.4.24 • Milvus 2.5.21 • Milvus 2.6.5 Users should upgrade to these patched versions or later to mitigate the vulnerability. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? If immediate upgrade is not possible, a temporary mitigation can be applied by removing the sourceID header from all incoming requests at the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mhjq-8c7m-3f7p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64513

Advisory: Milvus Proxy has a Critical Authentication Bypass Vulnerability
IDs: CVE-2025-64513, GHSA-mhjq-8c7m-3f7p
Record: https://patchnext.com/advisories/cve-2025-64513 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/milvus-io/milvus 2.6.5, 2.5.21, 2.4.24, 0.10.3-0.20251107071934-6102f001a971. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/milvus-io/milvus: affected >= 0.10.4, < 2.4.24; >= 2.5.0, < 2.5.21; >= 2.6.0, < 2.6.5; < 0.10.3-0.20251107071934-6102f001a971; fixed in 0.10.3-0.20251107071934-6102f001a971, 2.5.21, 2.6.5, 2.4.24

## Suggested inspection (read-only)
- Go github.com/milvus-io/milvus: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/milvus-io/milvus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mhjq-8c7m-3f7p (GitHub-reviewed advisory GHSA-mhjq-8c7m-3f7p lists affected ranges: Go github.com/milvus-io/milvus >=0.10.4 =2.5.0 =2.6.0 =0 <0.10.3-0.20251107071934-6102f001a971)

Commands are suggestions: review each one before running it.

Loading voting…