Skip to content

← Actionable
Medium, CVSS 6.9amended

Parse Server allows public explain queries which may expose sensitive database performance information and schema details

CVE-2025-64502GHSA-7cx5-254x-cgrq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 8.5.0-alpha.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse-server

    Affected
    < 8.5.0-alpha.5
    Fixed in
    8.5.0-alpha.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2025-64502: 0.45% estimated exploitation activity in the next 30 days; percentile 38.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The MongoDB explain() method provides detailed information about query execution plans, including index usage, collection scanning behavior, and performance metrics. Parse Server permits any client to execute explain queries without requiring the master key. This exposes: - Database schema structure and field names - Index configurations and query optimization details - Query execution statistics and performance metrics - Potential attack vectors for database performance exploitation Patches A new databaseOptions.allowPublicExplain configuration option has been introduced that allows to restrict explain queries to the master key. The option defaults to true for now to avoid a breaking change in production systems that depends on public explain availability. In addition, a security warning is logged when the option is not explicitly set, or set to true. In a future major release of Parse Server, the default will change to false. Workarounds Implementing middleware to block…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7cx5-254x-cgrq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7cx5-254x-cgrq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64502

Advisory: Parse Server allows public `explain` queries which may expose sensitive database performance information and schema details
IDs: CVE-2025-64502, GHSA-7cx5-254x-cgrq
Record: https://patchnext.com/advisories/cve-2025-64502 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse-server 8.5.0-alpha.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse-server: affected < 8.5.0-alpha.5; fixed in 8.5.0-alpha.5

## Suggested inspection (read-only)
- `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7cx5-254x-cgrq (OSV record GHSA-7cx5-254x-cgrq lists affected ranges: npm parse-server >=0 <8.5.0-alpha.5 (fixed))
- Verified: https://github.com/advisories/GHSA-7cx5-254x-cgrq (GitHub-reviewed advisory GHSA-7cx5-254x-cgrq lists affected ranges: npm parse-server >=0 <8.5.0-alpha.5)

Commands are suggestions: review each one before running it.

Loading voting…