Open WebUI Affected by an External Model Server (Direct Connections) Code Injection via SSE Events
CVE-2025-64496GHSA-cm35-v4vp-5xvx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.6.35; open-webui 0.6.35), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm open-webui
- Affected
- <= 0.6.34
- Fixed in
- 0.6.35
PyPI open-webui
- Affected
- <= 0.6.34
- Fixed in
- 0.6.35
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cm35-v4vp-5xvx lists affected ranges: npm open-webui >=0 =0 <0.6.35 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cm35-v4vp-5xvx lists affected ranges: npm open-webui >=0 =0 <=0.6.34
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-64496: 7.23% estimated exploitation activity in the next 30 days; percentile 94.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Open WebUI v0.6.33 and below contains a code injection vulnerability in the Direct Connections feature that allows malicious external model servers to execute arbitrary JavaScript in victim browsers via Server-Sent Event (SSE) execute events. This leads to authentication token theft, complete account takeover, and when chained with the Functions API, enables remote code execution on the backend server. The attack requires the victim to enable Direct Connections (disabled by default) and add the attacker's malicious model URL, achievable through social engineering of the admin and subsequent users. Details ROOT CAUSE ANALYSIS: Open WebUI's Direct Connections feature allows users to add external OpenAI-compatible model servers without proper validation of the Server-Sent Events (SSE) these servers emit. VULNERABLE COMPONENT: Frontend SSE Event Handler The frontend JavaScript code processes SSE events from external servers and specifically handles an execute event type that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cm35-v4vp-5xvx
- Revision 1 · created ·
Published from osv record GHSA-cm35-v4vp-5xvx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64496 Advisory: Open WebUI Affected by an External Model Server (Direct Connections) Code Injection via SSE Events IDs: CVE-2025-64496, GHSA-cm35-v4vp-5xvx Record: https://patchnext.com/advisories/cve-2025-64496 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: open-webui 0.6.35; open-webui 0.6.35. A vendor fix does not mean a deployment is fixed. ## Affected components - npm open-webui: affected <= 0.6.34; fixed in 0.6.35 - PyPI open-webui: affected <= 0.6.34; fixed in 0.6.35 ## Suggested inspection (read-only) - `npm ls open-webui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on open-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cm35-v4vp-5xvx (OSV record GHSA-cm35-v4vp-5xvx lists affected ranges: npm open-webui >=0 =0 <0.6.35 (fixed)) - Verified: https://github.com/advisories/GHSA-cm35-v4vp-5xvx (GitHub-reviewed advisory GHSA-cm35-v4vp-5xvx lists affected ranges: npm open-webui >=0 =0 <=0.6.34) Commands are suggestions: review each one before running it.
Loading voting…