Skip to content

← Actionable
High, CVSS 8.7amended

Open WebUI vulnerable to Stored DOM XSS via prompts when 'Insert Prompt as Rich Text' is enabled resulting in ATO/RCE

CVE-2025-64495GHSA-w7xj-8fx7-wfch

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.6.35; open-webui 0.6.35), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2025-64495: 0.49% estimated exploitation activity in the next 30 days; percentile 42.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The functionality that inserts custom prompts into the chat window is vulnerable to DOM XSS when 'Insert Prompt as Rich Text' is enabled, since the prompt body is assigned to the DOM sink .innerHtml without sanitisation. Any user with permissions to create prompts can abuse this to plant a payload that could be triggered by other users if they run the corresponding / command to insert the prompt. Details The affected line is https://github.com/open-webui/open-webui/blob/7a83e7dfa367d19f762ec17cac5e4a94ea2bd97d/src/lib/components/common/RichTextInput.svelte#L348 User controlled HTML from the prompt body is assigned to tempDiv.innerHTML without (meaningful) sanitisation. marked.parse introduces some character limitations but does not sanitise the content, as stated in their README. <img width="1816" height="498" alt="image" src="https://github.com/user-attachments/assets/bd0980fc-ad87-460a-94b8-02bc94bea1a2" / PoC Create a custom prompt as follows: <img width="3006"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w7xj-8fx7-wfch

  2. Revision 1 · created ·

    Published from osv record GHSA-w7xj-8fx7-wfch

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64495

Advisory: Open WebUI vulnerable to Stored DOM XSS via prompts when 'Insert Prompt as Rich Text' is enabled resulting in ATO/RCE
IDs: CVE-2025-64495, GHSA-w7xj-8fx7-wfch
Record: https://patchnext.com/advisories/cve-2025-64495 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.6.35; open-webui 0.6.35. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm open-webui: affected <= 0.6.34; fixed in 0.6.35
- PyPI open-webui: affected <= 0.6.34; fixed in 0.6.35

## Suggested inspection (read-only)
- `npm ls open-webui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w7xj-8fx7-wfch (OSV record GHSA-w7xj-8fx7-wfch lists affected ranges: npm open-webui >=0 =0 <0.6.35 (fixed))
- Verified: https://github.com/advisories/GHSA-w7xj-8fx7-wfch (GitHub-reviewed advisory GHSA-w7xj-8fx7-wfch lists affected ranges: npm open-webui >=0 =0 <=0.6.34)

Commands are suggestions: review each one before running it.

Loading voting…