OAuth2-Proxy is vulnerable to header smuggling via underscore leading to potential privilege escalation
CVE-2025-64484GHSA-vjrc-mh2v-45x6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/oauth2-proxy/oauth2-proxy/v7 7.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/oauth2-proxy/oauth2-proxy/v7
- Affected
- < 7.13.0
- Fixed in
- 7.13.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vjrc-mh2v-45x6 lists affected ranges: Go github.com/oauth2-proxy/oauth2-proxy/v7 >=0 <7.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2025-64484: 0.66% estimated exploitation activity in the next 30 days; percentile 51.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact All deployments of OAuth2 Proxy in front of applications that normalize underscores to dashes in HTTP headers (e.g., WSGI-based frameworks such as Django, Flask, FastAPI, and PHP applications). Authenticated users can inject underscore variants of X-Forwarded- headers that bypass the proxy’s filtering logic, potentially escalating privileges in the upstream app. OAuth2 Proxy authentication/authorization itself is not compromised. Patches This change mitigates a request header smuggling vulnerability where an attacker could bypass header stripping by using different capitalization or replacing dashes with underscores. The problem has been patched with v7.13.0. By default all specified headers will now be normalized, meaning that both capitalization and the use of underscores () versus dashes (-) will be ignored when matching headers to be stripped. For example, both X-Forwarded-For and XForwarded-for will now be treated as equivalent and stripped away. However, if users have a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vjrc-mh2v-45x6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64484 Advisory: OAuth2-Proxy is vulnerable to header smuggling via underscore leading to potential privilege escalation IDs: CVE-2025-64484, GHSA-vjrc-mh2v-45x6 Record: https://patchnext.com/advisories/cve-2025-64484 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/oauth2-proxy/oauth2-proxy/v7 7.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/oauth2-proxy/oauth2-proxy/v7: affected < 7.13.0; fixed in 7.13.0 ## Suggested inspection (read-only) - Go github.com/oauth2-proxy/oauth2-proxy/v7: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/oauth2-proxy/oauth2-proxy/v7. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vjrc-mh2v-45x6 (GitHub-reviewed advisory GHSA-vjrc-mh2v-45x6 lists affected ranges: Go github.com/oauth2-proxy/oauth2-proxy/v7 >=0 <7.13.0) Commands are suggestions: review each one before running it.
Loading voting…