LangGraph Checkpoint affected by RCE in "json" mode of JsonPlusSerializer
CVE-2025-64439GHSA-wwqv-p2pp-99h5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph-checkpoint 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langgraph-checkpoint
- Affected
- < 3.0.0
- Fixed in
- 3.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wwqv-p2pp-99h5 lists affected ranges: PyPI langgraph-checkpoint >=0 <3.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wwqv-p2pp-99h5 lists affected ranges: PyPI langgraph-checkpoint >=0 <3.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.4 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2025-64439: 0.89% estimated exploitation activity in the next 30 days; percentile 59.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Prior to langgraph-checkpoint version 3.0 , LangGraph’s JsonPlusSerializer (used as the default serialization protocol for all checkpointing) contains a remote code execution (RCE) vulnerability when deserializing payloads saved in the "json" serialization mode. If an attacker can cause your application to persist a payload serialized in this mode, they may be able to also send malicious content that executes arbitrary Python code during deserialization. Upgrading to version langgraph-checkpoint 3.0 patches this vulnerability by preventing deserialization of custom objects saved in this mode. If you are deploying in langgraph-api, any version 0.5 or later is also free of this vulnerability. Details Affected file / component jsonplus.py By default, the serializer attempts to use "msgpack" for serialization. However, prior to version 3.0 of the checkpointer library, if illegal Unicode surrogate values caused serialization to fail, it would fall back to using the "json" mode.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wwqv-p2pp-99h5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wwqv-p2pp-99h5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64439 Advisory: LangGraph Checkpoint affected by RCE in "json" mode of JsonPlusSerializer IDs: CVE-2025-64439, GHSA-wwqv-p2pp-99h5 Record: https://patchnext.com/advisories/cve-2025-64439 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langgraph-checkpoint 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langgraph-checkpoint: affected < 3.0.0; fixed in 3.0.0 ## Suggested inspection (read-only) - `python -m pip show langgraph-checkpoint`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langgraph-checkpoint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wwqv-p2pp-99h5 (OSV record GHSA-wwqv-p2pp-99h5 lists affected ranges: PyPI langgraph-checkpoint >=0 <3.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wwqv-p2pp-99h5 (GitHub-reviewed advisory GHSA-wwqv-p2pp-99h5 lists affected ranges: PyPI langgraph-checkpoint >=0 <3.0.0) Commands are suggestions: review each one before running it.
Loading voting…