Skip to content

← Actionable
Medium, CVSS 6.9

KubeVirt Excessive Role Permissions Could Enable Unauthorized VMI Migrations Between Nodes

CVE-2025-64436GHSA-7xgm-5prm-v5gc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kubevirt.io/kubevirt 1.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-64436: 0.28% estimated exploitation activity in the next 30 days; percentile 20.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The permissions granted to the virt-handler service account, such as the ability to update VMI and patch nodes, could be abused to force a VMI migration to an attacker-controlled node. Details Following the GitHub security advisory published on March 23 2023, a ValidatingAdmissionPolicy was introduced to impose restrictions on which sections of node resources the virt-handler service account can modify. For instance, the spec section of nodes has been made immutable, and modifications to the labels section are now limited to kubevirt.io-prefixed labels only. This vulnerability could otherwise allow an attacker to mark all nodes as unschedulable, potentially forcing the migration or creation of privileged pods onto a compromised node. However, if a virt-handler service account is compromised, either through the pod itself or the underlying node, an attacker may still modify node labels, both on the compromised node and on other nodes within the cluster. Notably, virt-handler…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7xgm-5prm-v5gc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64436

Advisory: KubeVirt Excessive Role Permissions Could Enable Unauthorized VMI Migrations Between Nodes
IDs: CVE-2025-64436, GHSA-7xgm-5prm-v5gc
Record: https://patchnext.com/advisories/cve-2025-64436 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kubevirt.io/kubevirt 1.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go kubevirt.io/kubevirt: affected < 1.7.0; fixed in 1.7.0

## Suggested inspection (read-only)
- Go kubevirt.io/kubevirt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kubevirt.io/kubevirt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7xgm-5prm-v5gc (GitHub-reviewed advisory GHSA-7xgm-5prm-v5gc lists affected ranges: Go kubevirt.io/kubevirt >=0 <1.7.0)

Commands are suggestions: review each one before running it.

Loading voting…