Skip to content

← Actionable
Medium, CVSS 5.3

KubeVirt VMI Denial-of-Service (DoS) Using Pod Impersonation

CVE-2025-64435GHSA-9m94-w2vq-hcf9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kubevirt.io/kubevirt 1.7.0-beta.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-64435: 0.41% estimated exploitation activity in the next 30 days; percentile 35.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Short summary of the problem. Make the impact and severity as clear as possible. A logic flaw in the virt-controller allows an attacker to disrupt the control over a running VMI by creating a pod with the same labels as the legitimate virt-launcher pod associated with the VMI. This can mislead the virt-controller into associating the fake pod with the VMI, resulting in incorrect status updates and potentially causing a DoS (Denial-of-Service). Details Give all details on the vulnerability. Pointing to the incriminated source code is very helpful for the maintainer. A vulnerability has been identified in the logic responsible for reconciling the state of VMI. Specifically, it is possible to associate a malicious attacker-controlled pod with an existing VMI running within the same namespace as the pod, thereby replacing the legitimate virt-launcher pod associated with the VMI. The virt-launcher pod is critical for enforcing the isolation mechanisms applied to the QEMU process…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9m94-w2vq-hcf9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64435

Advisory: KubeVirt VMI Denial-of-Service (DoS) Using Pod Impersonation
IDs: CVE-2025-64435, GHSA-9m94-w2vq-hcf9
Record: https://patchnext.com/advisories/cve-2025-64435 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kubevirt.io/kubevirt 1.7.0-beta.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go kubevirt.io/kubevirt: affected < 1.7.0-beta.0; fixed in 1.7.0-beta.0

## Suggested inspection (read-only)
- Go kubevirt.io/kubevirt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kubevirt.io/kubevirt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9m94-w2vq-hcf9 (GitHub-reviewed advisory GHSA-9m94-w2vq-hcf9 lists affected ranges: Go kubevirt.io/kubevirt >=0 <1.7.0-beta.0)

Commands are suggestions: review each one before running it.

Loading voting…