Skip to content

← Actionable
Medium, CVSS 4.7

KubeVirt's Improper TLS Certificate Management Handling Allows API Identity Spoofing

CVE-2025-64434GHSA-ggp9-c99x-54gp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kubevirt.io/kubevirt 1.6.1, 1.5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-64434: 0.20% estimated exploitation activity in the next 30 days; percentile 9.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Due to improper TLS certificate management, a compromised virt-handler could impersonate virt-api by using its own TLS credentials, allowing it to initiate privileged operations against another virt-handler. Details Give all details on the vulnerability. Pointing to the incriminated source code is very helpful for the maintainer. Because of improper TLS certificate management, a compromised virt-handler instance can reuse its TLS bundle to impersonate virt-api, enabling unauthorized access to VM lifecycle operations on other virt-handler nodes. The virt-api component acts as a sub-resource server, and it proxies API VM lifecycle requests to virt-handler instances. The communication between virt-api and virt-handler instances is secured using mTLS. The former acts as a client while the latter as the server. The client certificate used by virt-api is defined in the source code as follows and have the following properties: The virt-handler component verifies the signature of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ggp9-c99x-54gp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64434

Advisory: KubeVirt's Improper TLS Certificate Management Handling Allows API Identity Spoofing
IDs: CVE-2025-64434, GHSA-ggp9-c99x-54gp
Record: https://patchnext.com/advisories/cve-2025-64434 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kubevirt.io/kubevirt 1.6.1, 1.5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go kubevirt.io/kubevirt: affected < 1.5.3; >= 1.6.0-alpha.0, < 1.6.1; fixed in 1.6.1, 1.5.3

## Suggested inspection (read-only)
- Go kubevirt.io/kubevirt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kubevirt.io/kubevirt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ggp9-c99x-54gp (GitHub-reviewed advisory GHSA-ggp9-c99x-54gp lists affected ranges: Go kubevirt.io/kubevirt >=0 =1.6.0-alpha.0 <1.6.1)

Commands are suggestions: review each one before running it.

Loading voting…