Skip to content

← Actionable
Medium, CVSS 4.7

KubeVirt Affected by an Authentication Bypass in Kubernetes Aggregation Layer

CVE-2025-64432GHSA-38jw-g2qx-4286

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (kubevirt.io/kubevirt 1.7.0-rc.0, 1.6.1, 1.5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go kubevirt.io/kubevirt

    Affected
    < 1.5.3>= 1.6.0-alpha.0, < 1.6.1>= 1.7.0-alpha.0, < 1.7.0-rc.0
    Fixed in
    1.6.1, 1.7.0-rc.0, 1.5.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-64432: 0.15% estimated exploitation activity in the next 30 days; percentile 3.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Short summary of the problem. Make the impact and severity as clear as possible. A flawed implementation of the Kubernetes aggregation layer's authentication flow could enable bypassing RBAC controls. Details Give all details on the vulnerability. Pointing to the incriminated source code is very helpful for the maintainer. It was discovered that the virt-api component fails to correctly authenticate the client when receiving API requests over mTLS. In particular, it fails to validate the CN (Common Name) field in the received client TLS certificates against the set of allowed values defined in the extension-apiserver-authentication configmap. The Kubernetes API server proxies received client requests through a component called aggregator (part of K8S's API server), and authenticates to the virt-api server using a certificate signed by the CA specified via the --requestheader-client-ca-file CLI flag. This CA bundle is primarily used in the context of aggregated API servers,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-38jw-g2qx-4286

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64432

Advisory: KubeVirt Affected by an Authentication Bypass in Kubernetes Aggregation Layer
IDs: CVE-2025-64432, GHSA-38jw-g2qx-4286
Record: https://patchnext.com/advisories/cve-2025-64432 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: kubevirt.io/kubevirt 1.7.0-rc.0, 1.6.1, 1.5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go kubevirt.io/kubevirt: affected < 1.5.3; >= 1.6.0-alpha.0, < 1.6.1; >= 1.7.0-alpha.0, < 1.7.0-rc.0; fixed in 1.6.1, 1.7.0-rc.0, 1.5.3

## Suggested inspection (read-only)
- Go kubevirt.io/kubevirt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on kubevirt.io/kubevirt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-38jw-g2qx-4286 (GitHub-reviewed advisory GHSA-38jw-g2qx-4286 lists affected ranges: Go kubevirt.io/kubevirt >=0 =1.6.0-alpha.0 =1.7.0-alpha.0 <1.7.0-rc.0)

Commands are suggestions: review each one before running it.

Loading voting…