Parse Server Vulnerable to Server-Side Request Forgery (SSRF) in File Upload via URI Format
CVE-2025-64430GHSA-x4qj-2f4q-r4rx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 8.4.0-alpha.2, 7.5.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 4.2.0, < 7.5.4>= 8.0.0, <= 8.4.0-alpha.1
- Fixed in
- 7.5.4, 8.4.0-alpha.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x4qj-2f4q-r4rx lists affected ranges: npm parse-server >=4.2.0 =8.0.0 <8.4.0-alpha.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x4qj-2f4q-r4rx lists affected ranges: npm parse-server >=4.2.0 =8.0.0 <=8.4.0-alpha.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-64430: 0.65% estimated exploitation activity in the next 30 days; percentile 50.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Server-Side Request Forgery (SSRF) vulnerability in the file upload functionality when trying to upload a Parse.File with uri parameter allows to execute an arbitrary URI. The vulnerability stems from a file upload feature in which Parse Server retrieves the file data from a URI that is provided in the request. A request to the provided URI is executed, but the response is not stored in Parse Server's file storage as the server crashes upon receiving the response. Patches The feature has been implemented in Parse Server 4.2.0 but never worked and reliably crashes the server when trying to use it due to a bug in its implementation. Since the feature is not currently working, and due to its risky nature, it has been removed to address the vulnerability. Workarounds None.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x4qj-2f4q-r4rx
- Revision 1 · created ·
Published from osv record GHSA-x4qj-2f4q-r4rx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64430 Advisory: Parse Server Vulnerable to Server-Side Request Forgery (SSRF) in File Upload via URI Format IDs: CVE-2025-64430, GHSA-x4qj-2f4q-r4rx Record: https://patchnext.com/advisories/cve-2025-64430 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 8.4.0-alpha.2, 7.5.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 4.2.0, < 7.5.4; >= 8.0.0, <= 8.4.0-alpha.1; fixed in 7.5.4, 8.4.0-alpha.2 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x4qj-2f4q-r4rx (OSV record GHSA-x4qj-2f4q-r4rx lists affected ranges: npm parse-server >=4.2.0 =8.0.0 <8.4.0-alpha.2 (fixed)) - Verified: https://github.com/advisories/GHSA-x4qj-2f4q-r4rx (GitHub-reviewed advisory GHSA-x4qj-2f4q-r4rx lists affected ranges: npm parse-server >=4.2.0 =8.0.0 <=8.4.0-alpha.1) Commands are suggestions: review each one before running it.
Loading voting…