Apollo Router Improperly Enforces Renamed Access Control Directives
CVE-2025-64347GHSA-g8jh-vg5j-4h3f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apollo-router 2.8.1, 1.61.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io apollo-router
- Affected
- < 1.61.12>= 2.0.0-alpha.0, < 2.8.1
- Fixed in
- 2.8.1, 1.61.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g8jh-vg5j-4h3f lists affected ranges: crates.io apollo-router >=0 =2.0.0-alpha.0 <2.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-64347: 0.33% estimated exploitation activity in the next 30 days; percentile 25.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A vulnerability in Apollo Router allowed for unauthorized access to protected data through schema elements with access control directives (@authenticated, @requiresScopes, and @policy) that were renamed via @link imports. Router did not enforce renamed access control directives on schema elements (e.g. fields and types), allowing queries to bypass those element-level access controls. Details Apollo Federation allows users to specify access control directives (@authenticated, @requiresScopes, and @policy](https://www.apollographql.com/docs/graphos/routing/security/authorization#authorization-directives)) to protect schema data access at the element level. These directives can optionally be renamed via the imports argument to the @link directive, which can be useful if their default names match an existing user-defined directive in their subgraph schema. However, Apollo Router's access control logic ignored the imports argument, and would accordingly ignore access control…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g8jh-vg5j-4h3f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64347 Advisory: Apollo Router Improperly Enforces Renamed Access Control Directives IDs: CVE-2025-64347, GHSA-g8jh-vg5j-4h3f Record: https://patchnext.com/advisories/cve-2025-64347 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apollo-router 2.8.1, 1.61.12. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io apollo-router: affected < 1.61.12; >= 2.0.0-alpha.0, < 2.8.1; fixed in 2.8.1, 1.61.12 ## Suggested inspection (read-only) - crates.io apollo-router: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apollo-router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g8jh-vg5j-4h3f (GitHub-reviewed advisory GHSA-g8jh-vg5j-4h3f lists affected ranges: crates.io apollo-router >=0 =2.0.0-alpha.0 <2.8.1) Commands are suggestions: review each one before running it.
Loading voting…