Skip to content

← Actionable
Medium, CVSS 6.0

github.com/jaredallard/archives Has Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

CVE-2025-64346GHSA-j95m-rcjp-q69h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/jaredallard/archives 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-64346: 0.39% estimated exploitation activity in the next 30 days; percentile 32.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A malicious user could feed a specially crafted archive to this library causing RCE, modification of files or other bad things in the context of whatever user is running this library as, through the program that imports it. The severity highly depends on the user's permissions and environment it is being ran in (e.g., non root, read only root container would likely have no impact vs running something as root on a production system). The severity is also dependent on arbitrary archives being passed or not. Based on the above, severity high was picked to be safe. Patches Patched with the help of snyk and gosec in v1.0.1 Workarounds The only workaround is to manually validate archives before submitting them to this library, however that is not recommended vs upgrading to unaffected versions. References https://security.snyk.io/research/zip-slip-vulnerability

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j95m-rcjp-q69h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64346

Advisory: github.com/jaredallard/archives Has Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
IDs: CVE-2025-64346, GHSA-j95m-rcjp-q69h
Record: https://patchnext.com/advisories/cve-2025-64346 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/jaredallard/archives 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/jaredallard/archives: affected < 1.0.1; fixed in 1.0.1

## Suggested inspection (read-only)
- Go github.com/jaredallard/archives: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/jaredallard/archives.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j95m-rcjp-q69h (GitHub-reviewed advisory GHSA-j95m-rcjp-q69h lists affected ranges: Go github.com/jaredallard/archives >=0 <1.0.1)

Commands are suggestions: review each one before running it.

Loading voting…