FastMCP has a Command Injection vulnerability - Gemini CLI
CVE-2025-64340GHSA-m8x7-r2rg-vh5g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastmcp 3.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI fastmcp
- Affected
- < 3.2.0
- Fixed in
- 3.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m8x7-r2rg-vh5g lists affected ranges: PyPI fastmcp >=0 <3.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m8x7-r2rg-vh5g lists affected ranges: PyPI fastmcp >=0 <3.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-64340: 0.75% estimated exploitation activity in the next 30 days; percentile 54.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Server names containing shell metacharacters (e.g., &) can cause command injection on Windows when passed to fastmcp install claude-code or fastmcp install gemini-cli. These install paths use subprocess.run() with a list argument, but on Windows the target CLIs often resolve to .cmd wrappers that are executed through cmd.exe, which interprets metacharacters in the flattened command string. PoC: On Windows, this opens Calculator via the &calc in the server name. Impact: Arbitrary command execution with the privileges of the user running fastmcp install. Affects Windows hosts where the target CLI (one of claude, gemini) is installed as a .cmd wrapper. Does not affect macOS/Linux, and does not affect config-file-based install targets (cursor, goose, mcp-json). Patched in #3522 by validating server names to reject shell metacharacters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m8x7-r2rg-vh5g
- Revision 1 · created ·
Published from osv record GHSA-m8x7-r2rg-vh5g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64340 Advisory: FastMCP has a Command Injection vulnerability - Gemini CLI IDs: CVE-2025-64340, GHSA-m8x7-r2rg-vh5g Record: https://patchnext.com/advisories/cve-2025-64340 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastmcp 3.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI fastmcp: affected < 3.2.0; fixed in 3.2.0 ## Suggested inspection (read-only) - `python -m pip show fastmcp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastmcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m8x7-r2rg-vh5g (OSV record GHSA-m8x7-r2rg-vh5g lists affected ranges: PyPI fastmcp >=0 <3.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-m8x7-r2rg-vh5g (GitHub-reviewed advisory GHSA-m8x7-r2rg-vh5g lists affected ranges: PyPI fastmcp >=0 <3.2.0) Commands are suggestions: review each one before running it.
Loading voting…