Skip to content

← Actionable
Medium, CVSS 6.9

containerd CRI server: Host memory exhaustion through Attach goroutine leak

CVE-2025-64329GHSA-m6hq-p25p-ffr2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd/v2 2.2.0, 2.1.5, 2.0.7; github.com/containerd/containerd 1.7.29), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-64329: 0.17% estimated exploitation activity in the next 30 days; percentile 6.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A bug was found in containerd's CRI Attach implementation where a user can exhaust memory on the host due to goroutine leaks. Repetitive calls of CRI Attach (e.g., kubectl attach) could increase the memory usage of containerd. Patches This bug has been fixed in the following containerd versions: 2.2.0 2.1.5 2.0.7 1.7.29 Users should update to these versions to resolve the issue. Workarounds Set up an admission controller to control accesses to pods/attach resources. e.g., Validating Admission Policy. Credits The containerd project would like to thank @Wheat2018 for responsibly disclosing this issue in accordance with the containerd security policy. References https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2025-64329 For more information If you have any questions or comments about this advisory: Open an issue in containerd Email us at security@containerd.io To report a security issue in containerd: Report a new vulnerability

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m6hq-p25p-ffr2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64329

Advisory: containerd CRI server: Host memory exhaustion through Attach goroutine leak
IDs: CVE-2025-64329, GHSA-m6hq-p25p-ffr2
Record: https://patchnext.com/advisories/cve-2025-64329 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd/v2 2.2.0, 2.1.5, 2.0.7; github.com/containerd/containerd 1.7.29. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containerd/containerd/v2: affected < 2.0.7; >= 2.1.0-beta.0, < 2.1.5; >= 2.2.0-beta.0, < 2.2.0; fixed in 2.2.0, 2.1.5, 2.0.7
- Go github.com/containerd/containerd: affected < 1.7.29; fixed in 1.7.29

## Suggested inspection (read-only)
- Go github.com/containerd/containerd/v2: check the installed version with your package manager.
- Go github.com/containerd/containerd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containerd/containerd/v2, github.com/containerd/containerd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m6hq-p25p-ffr2 (GitHub-reviewed advisory GHSA-m6hq-p25p-ffr2 lists affected ranges: Go github.com/containerd/containerd >=0 =0 =2.1.0-beta.0 =2.2.0-beta.0 <2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…