OctoPrint vulnerable to XSS in Action Commands Notification and Prompt
CVE-2025-64187GHSA-crvm-xjhm-9h29
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 1.11.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI octoprint
- Affected
- <= 1.11.3
- Fixed in
- 1.11.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-crvm-xjhm-9h29 lists affected ranges: PyPI octoprint >=0 <1.11.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-crvm-xjhm-9h29 lists affected ranges: PyPI octoprint >=0 <=1.11.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-64187: 0.17% estimated exploitation activity in the next 30 days; percentile 6.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact OctoPrint versions up to and including 1.11.3 are affected by a vulnerability that allows injection of arbitrary HTML and JavaScript into Action Command notification and prompt popups generated by the printer. An attacker who successfully convinces a victim to print a specially crafted file could exploit this issue to disrupt ongoing prints, extract information (including sensitive configuration settings, if the targeted user has the necessary permissions for that), or perform other actions on behalf of the targeted user within the OctoPrint instance. Patches The vulnerability will be patched in version 1.11.4. Workaround OctoPrint administrators can mitigate the risk by disabling popups: - for Action Command notifications, uncheck OctoPrint Settings - Printer Notifications - Enable popups - for Action Command prompts, set OctoPrint Settings - Printer Dialogs - Enable support - Never It is also strongly recommended to ensure that files being printed originate from trusted…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-crvm-xjhm-9h29
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-crvm-xjhm-9h29
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64187 Advisory: OctoPrint vulnerable to XSS in Action Commands Notification and Prompt IDs: CVE-2025-64187, GHSA-crvm-xjhm-9h29 Record: https://patchnext.com/advisories/cve-2025-64187 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: octoprint 1.11.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI octoprint: affected <= 1.11.3; fixed in 1.11.4 ## Suggested inspection (read-only) - `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on octoprint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-crvm-xjhm-9h29 (OSV record GHSA-crvm-xjhm-9h29 lists affected ranges: PyPI octoprint >=0 <1.11.4 (fixed)) - Verified: https://github.com/advisories/GHSA-crvm-xjhm-9h29 (GitHub-reviewed advisory GHSA-crvm-xjhm-9h29 lists affected ranges: PyPI octoprint >=0 <=1.11.3) Commands are suggestions: review each one before running it.
Loading voting…