OpenEXR has use after free in PyObject_StealAttrString
CVE-2025-64183GHSA-57cw-j6vp-2p9m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openexr 3.4.3, 3.3.6, 3.2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI openexr
- Affected
- >= 3.2.0, < 3.2.5>= 3.3.0, < 3.3.6>= 3.4.0, < 3.4.3
- Fixed in
- 3.3.6, 3.2.5, 3.4.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-57cw-j6vp-2p9m lists affected ranges: PyPI openexr >=3.2.0 =3.3.0 =3.4.0 <3.4.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-57cw-j6vp-2p9m lists affected ranges: PyPI openexr >=3.2.0 =3.3.0 =3.4.0 <3.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-64183: 0.32% estimated exploitation activity in the next 30 days; percentile 25.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There is a use-after-free in PyObjectStealAttrString of pyOpenEXRold.cpp. This bug was found with ZeroPath. Details The legacy adapter defines PyObjectStealAttrString that calls PyObjectGetAttrString to obtain a new reference, immediately decrefs it, and returns the pointer. Callers then pass this dangling pointer to APIs like PyLongAsLong/PyFloatAsDouble, resulting in a use-after-free. This is invoked in multiple places (e.g., reading PixelType.v, Box2i, V2f, etc.). https://github.com/AcademySoftwareFoundation/openexr/blob/b3a19903db0672c63055023aa788e592b16ec3c5/src/wrappers/python/PyOpenEXRold.cpp#L109-L115 https://github.com/AcademySoftwareFoundation/openexr/blob/b3a19903db0672c63055023aa788e592b16ec3c5/src/wrappers/python/PyOpenEXRold.cpp#L380-L387 https://github.com/AcademySoftwareFoundation/openexr/blob/b3a19903db0672c63055023aa788e592b16ec3c5/src/wrappers/python/PyOpenEXRold.cpp#L1258-L1286 PoC running Impact Completely depends on the context. Typical memory stuff…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-57cw-j6vp-2p9m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-57cw-j6vp-2p9m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64183 Advisory: OpenEXR has use after free in PyObject_StealAttrString IDs: CVE-2025-64183, GHSA-57cw-j6vp-2p9m Record: https://patchnext.com/advisories/cve-2025-64183 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openexr 3.4.3, 3.3.6, 3.2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI openexr: affected >= 3.2.0, < 3.2.5; >= 3.3.0, < 3.3.6; >= 3.4.0, < 3.4.3; fixed in 3.3.6, 3.2.5, 3.4.3 ## Suggested inspection (read-only) - `python -m pip show openexr`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openexr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-57cw-j6vp-2p9m (OSV record GHSA-57cw-j6vp-2p9m lists affected ranges: PyPI openexr >=3.2.0 =3.3.0 =3.4.0 <3.4.3 (fixed)) - Verified: https://github.com/advisories/GHSA-57cw-j6vp-2p9m (GitHub-reviewed advisory GHSA-57cw-j6vp-2p9m lists affected ranges: PyPI openexr >=3.2.0 =3.3.0 =3.4.0 <3.4.3) Commands are suggestions: review each one before running it.
Loading voting…