Skip to content

← Actionable
Low, CVSS 2.0amended

OpenEXR Makes Use of Uninitialized Memory

CVE-2025-64181GHSA-3h9h-qfvw-98hq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openexr 3.4.3, 3.3.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI openexr

    Affected
    >= 3.3.0, < 3.3.6>= 3.4.0, < 3.4.3
    Fixed in
    3.3.6, 3.4.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.0 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-64181: 0.41% estimated exploitation activity in the next 30 days; percentile 35.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary While fuzzing openexrexrcheckfuzzer, Valgrind reports a conditional branch depending on uninitialized data inside genericunpack. This indicates a use of uninitialized memory (CWE-457). The issue is reproducible with the current OSS-Fuzz harness and a single-file PoC. Details Environment: - Tooling: valgrind --tool=memcheck --track-origins=yes - Target: openexrexrcheckfuzzer - OS: Ubuntu 20.04.6 LTS focal x8664 - openexr version and Git-commit hash: openexr 3.4.2 | commit fd657e8a41e157e5841c7cc2e2a5efe094b069a1 (grafted, HEAD - main, origin/main, origin/HEAD) Function: genericunpack Possible root cause (based on observed symptoms): The unpacker is branching on bytes in a scratch buffer that were never written because the decode step didn’t fully populate it. - The first use flagged is in genericunpack(). That function reads from the decompressed/expanded pixel buffer to scatter data into the framebuffer. A “conditional jump depends on uninitialised value(s)” means it’s…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3h9h-qfvw-98hq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3h9h-qfvw-98hq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64181

Advisory: OpenEXR Makes Use of Uninitialized Memory
IDs: CVE-2025-64181, GHSA-3h9h-qfvw-98hq
Record: https://patchnext.com/advisories/cve-2025-64181 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openexr 3.4.3, 3.3.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openexr: affected >= 3.3.0, < 3.3.6; >= 3.4.0, < 3.4.3; fixed in 3.3.6, 3.4.3

## Suggested inspection (read-only)
- `python -m pip show openexr`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openexr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3h9h-qfvw-98hq (OSV record GHSA-3h9h-qfvw-98hq lists affected ranges: PyPI openexr >=3.3.0 =3.4.0 <3.4.3 (fixed))
- Verified: https://github.com/advisories/GHSA-3h9h-qfvw-98hq (GitHub-reviewed advisory GHSA-3h9h-qfvw-98hq lists affected ranges: PyPI openexr >=3.3.0 =3.4.0 <3.4.3)

Commands are suggestions: review each one before running it.

Loading voting…