Mercurius: Incorrect Content-Type parsing can lead to CSRF attack
CVE-2025-64166GHSA-v66j-6wwf-jc57
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mercurius 16.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mercurius
- Affected
- <= 16.3.0
- Fixed in
- 16.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v66j-6wwf-jc57 lists affected ranges: npm mercurius >=0 <16.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v66j-6wwf-jc57 lists affected ranges: npm mercurius >=0 <=16.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-64166: 0.18% estimated exploitation activity in the next 30 days; percentile 8.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Cross-Site Request Forgery (CSRF) vulnerability was identified in Mercurius versions 16. The issue arises from incorrect parsing of the Content-Type header in requests. Specifically, requests with Content-Type values such as application/x-www-form-urlencoded, multipart/form-data, or text/plain could be misinterpreted as application/json. This misinterpretation bypasses the preflight checks performed by the fetch() API, potentially allowing unauthorized actions to be performed on behalf of an authenticated user. --- Impact An attacker could exploit this vulnerability by crafting a malicious request with a Content-Type that Fastify incorrectly parses as application/json. When such a request is made from a different origin, it bypasses the Cross-Origin Resource Sharing (CORS) protections, leading to a potential CSRF attack. This could result in unauthorized actions being performed on behalf of an authenticated user without their consent. --- Proof of Concept In the above…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v66j-6wwf-jc57
- Revision 1 · created ·
Published from osv record GHSA-v66j-6wwf-jc57
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-64166 Advisory: Mercurius: Incorrect Content-Type parsing can lead to CSRF attack IDs: CVE-2025-64166, GHSA-v66j-6wwf-jc57 Record: https://patchnext.com/advisories/cve-2025-64166 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mercurius 16.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mercurius: affected <= 16.3.0; fixed in 16.4.0 ## Suggested inspection (read-only) - `npm ls mercurius --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mercurius. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v66j-6wwf-jc57 (OSV record GHSA-v66j-6wwf-jc57 lists affected ranges: npm mercurius >=0 <16.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-v66j-6wwf-jc57 (GitHub-reviewed advisory GHSA-v66j-6wwf-jc57 lists affected ranges: npm mercurius >=0 <=16.3.0) Commands are suggestions: review each one before running it.
Loading voting…