Skip to content

← Actionable
Medium, CVSS 6.1amended

node-tar has a race condition leading to uninitialized memory exposure

CVE-2025-64118GHSA-29xp-372q-xqph

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tar 7.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tar

    Affected
    >= 7.5.1, <= 7.5.1
    Fixed in
    7.5.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.1 · CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:L/VA:L/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-64118: 0.13% estimated exploitation activity in the next 30 days; percentile 2.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Using .t (aka .list) with { sync: true } to read tar entry contents returns uninitialized memory contents if tar file was changed on disk to a smaller size while being read. Details See: https://github.com/isaacs/node-tar/issues/445 https://github.com/isaacs/node-tar/pull/446 Regression happened in https://github.com/isaacs/node-tar/commit/5330eb04bc43014f216e5c271b40d5c00d45224d PoC A: B (vulnerable): Run A and B in parallel on Node.js 22 or =25.1.0 Dumps B memory (wait for some time to observe text data) Impact Exposes process memory and could result in e.g. unintentionally (aka attacker-controlled) attempting to process sensitive data rather than tar entry contents. Uninitialized memory can contain unrelated file contents, environment variables, passwords, etc. To execute, an attacker must reduce the file size to boundary between a tar header and body block, in the time between when the tar archive file size is read via stat, and the time when the tar archive parser…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-29xp-372q-xqph

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-29xp-372q-xqph

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64118

Advisory: node-tar has a race condition leading to uninitialized memory exposure
IDs: CVE-2025-64118, GHSA-29xp-372q-xqph
Record: https://patchnext.com/advisories/cve-2025-64118 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tar 7.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tar: affected >= 7.5.1, <= 7.5.1; fixed in 7.5.2

## Suggested inspection (read-only)
- `npm ls tar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-29xp-372q-xqph (OSV record GHSA-29xp-372q-xqph lists affected ranges: npm tar >=7.5.1 <7.5.2 (fixed))
- Verified: https://github.com/advisories/GHSA-29xp-372q-xqph (GitHub-reviewed advisory GHSA-29xp-372q-xqph lists affected ranges: npm tar >=7.5.1 <=7.5.1)

Commands are suggestions: review each one before running it.

Loading voting…