Skip to content

← Actionable
Medium, CVSS 6.4

DNN vulnerable to stored cross-site-scripting (XSS) via SVG upload

CVE-2025-64094GHSA-hmvq-8p83-cq52

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dotnetnuke.core 10.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2025-64094: 0.19% estimated exploitation activity in the next 30 days; percentile 9.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Sanitization of the content of uploaded SVG files was not covering all possible XSS scenarios. Details DNN validates the contents of SVG's to ensure they are valid and do not contain any malicious code. These checks were introduced as part of CVE-2025-48378. However, the checks to ensure there are no script elements within the SVG files are not comprehensive and may allow some malicious SVG files to be uploaded. As this vulnerability allows for the execution of arbitrary JavaScript code within the context of the user's browser, it can lead to a range of attacks, including data exfiltration, session hijacking, and defacement of the web application to name a few.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hmvq-8p83-cq52

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-64094

Advisory: DNN vulnerable to stored cross-site-scripting (XSS) via SVG upload
IDs: CVE-2025-64094, GHSA-hmvq-8p83-cq52
Record: https://patchnext.com/advisories/cve-2025-64094 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dotnetnuke.core 10.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet dotnetnuke.core: affected < 10.1.1; fixed in 10.1.1

## Suggested inspection (read-only)
- NuGet dotnetnuke.core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dotnetnuke.core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hmvq-8p83-cq52 (GitHub-reviewed advisory GHSA-hmvq-8p83-cq52 lists affected ranges: NuGet dotnetnuke.core >=0 <10.1.1)

Commands are suggestions: review each one before running it.

Loading voting…