FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name
CVE-2025-62801GHSA-rj5c-58rq-j5g5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastmcp 2.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI fastmcp
- Affected
- < 2.13.0
- Fixed in
- 2.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rj5c-58rq-j5g5 lists affected ranges: PyPI fastmcp >=0 <2.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rj5c-58rq-j5g5 lists affected ranges: PyPI fastmcp >=0 <2.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.4 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-62801: 0.23% estimated exploitation activity in the next 30 days; percentile 13.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A command-injection vulnerability lets any attacker who can influence the servername field of an MCP execute arbitrary OS commands on Windows hosts that run fastmcp install cursor Details 1. generatecursordeeplink(servername, …) embeds servername verbatim in a cursor://…?name= query string. 2. opendeeplink() is invoked with shell=True only on Windows. That calls cmd.exe /c start <deeplink. 3. Any cmd metacharacter inside servername (&, |, , ^, …) escapes the start command and spawns an attacker-chosen process. PoC server.py then run in the terminal: fastmcp install cursor server.py Impact OS Command / Shell Injection (CWE-78) Every Windows host that runs fastmcp install cursor is at risk. Developers on their local workstations, CI/CD agents and corporate build machines alike.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rj5c-58rq-j5g5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-rj5c-58rq-j5g5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62801 Advisory: FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name IDs: CVE-2025-62801, GHSA-rj5c-58rq-j5g5 Record: https://patchnext.com/advisories/cve-2025-62801 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastmcp 2.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI fastmcp: affected < 2.13.0; fixed in 2.13.0 ## Suggested inspection (read-only) - `python -m pip show fastmcp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastmcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rj5c-58rq-j5g5 (OSV record GHSA-rj5c-58rq-j5g5 lists affected ranges: PyPI fastmcp >=0 <2.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rj5c-58rq-j5g5 (GitHub-reviewed advisory GHSA-rj5c-58rq-j5g5 lists affected ranges: PyPI fastmcp >=0 <2.13.0) Commands are suggestions: review each one before running it.
Loading voting…