Skip to content

← Actionable
Medium, CVSS 5.4

Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntax

CVE-2025-62798GHSA-9f58-4465-23c7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code16/sharp 9.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2025-62798: 0.22% estimated exploitation activity in the next 30 days; percentile 12.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component. In affected versions, expressions wrapped in {{ & }} were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed. For example, if a field’s value contains {{ Math.random() }}, it will be executed instead of being displayed as text. Impact Attackers who can control content rendered through SharpShowTextField could execute arbitrary JavaScript in the context of an authenticated user’s browser. This could lead to: - Theft of user session tokens. - Unauthorized actions performed on behalf of users. - Injection of malicious content into the admin panel. Patches The issue has been fixed in v9.11.1 of code16/sharp package. Mitigation / Workarounds Sanitize or encode any user-provided data that may include ({{ & }}) before displaying it in a SharpShowTextField.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9f58-4465-23c7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62798

Advisory: Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntax
IDs: CVE-2025-62798, GHSA-9f58-4465-23c7
Record: https://patchnext.com/advisories/cve-2025-62798 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code16/sharp 9.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist code16/sharp: affected < 9.11.1; fixed in 9.11.1

## Suggested inspection (read-only)
- Packagist code16/sharp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code16/sharp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9f58-4465-23c7 (GitHub-reviewed advisory GHSA-9f58-4465-23c7 lists affected ranges: Packagist code16/sharp >=0 <9.11.1)

Commands are suggestions: review each one before running it.

Loading voting…