InventoryGui allows item duplication in GUIs which use GuiStorageElement
CVE-2025-62784GHSA-7whh-79j3-7c55
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (de.themoep:inventorygui 1.6.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven de.themoep:inventorygui
- Affected
- < 1.6.5
- Fixed in
- 1.6.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7whh-79j3-7c55 lists affected ranges: Maven de.themoep:inventorygui >=0 <1.6.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N · score source
- EPSS
- CVE-2025-62784: 0.22% estimated exploitation activity in the next 30 days; percentile 13.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any plugin using a GUI with the GuiStorageElement and allows taking out items out of that element. Patches InventoryGui 1.6.5 (included in latest 1.6.5-SNAPSHOT) by disabling GuiStorageElement when not running on 1.21.9 or later. Workarounds Not using the GuiStorageElement.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7whh-79j3-7c55
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62784 Advisory: InventoryGui allows item duplication in GUIs which use GuiStorageElement IDs: CVE-2025-62784, GHSA-7whh-79j3-7c55 Record: https://patchnext.com/advisories/cve-2025-62784 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: de.themoep:inventorygui 1.6.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven de.themoep:inventorygui: affected < 1.6.5; fixed in 1.6.5 ## Suggested inspection (read-only) - Maven de.themoep:inventorygui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on de.themoep:inventorygui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7whh-79j3-7c55 (GitHub-reviewed advisory GHSA-7whh-79j3-7c55 lists affected ranges: Maven de.themoep:inventorygui >=0 <1.6.5) Commands are suggestions: review each one before running it.
Loading voting…