Skip to content

← Actionable
Low, CVSS 3.5amended

changedetection.io: Stored XSS in Watch update via API

CVE-2025-62780GHSA-4c3j-3h7v-22q9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (changedetection-io 0.50.34), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-62780: 0.46% estimated exploitation activity in the next 30 days; percentile 40.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Stored Cross Site Scripting is present in the changedetection.io Watch update API due to unsufficient security checks. Details Tested on changedetection.io version v0.50.24 When a user tries to add an unsafe URL as a Watch in the changedetection.io UI, the action is blocked with the error message "Watch protocol is not permitted by SAFEPROTOCOLREGEX or incorrect URL format". This is catched by the function validateurl(testurl). When instead the Watch API is used, this check is not performed resulting in unsafe URLs added as Watch. PoC Update an existing watch with an unsafe URL Impact Two scenarios are possibile: 1. An attacker can insert a new watch with an arbitrary URL which really points to a web page. Once the HTML content is retrieved, the attacker updates the URL with a JavaScript payload. 2. An attacker substitutes the URL in an existing watch with a new URL that is in reality a JavaScript payload. When the user clicks on Preview and then on the malicious link, the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4c3j-3h7v-22q9

  2. Revision 1 · created ·

    Published from osv record GHSA-4c3j-3h7v-22q9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62780

Advisory: changedetection.io: Stored XSS in Watch update via API
IDs: CVE-2025-62780, GHSA-4c3j-3h7v-22q9
Record: https://patchnext.com/advisories/cve-2025-62780 (revision 2, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: changedetection-io 0.50.34. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI changedetection-io: affected < 0.50.34; fixed in 0.50.34

## Suggested inspection (read-only)
- `python -m pip show changedetection-io`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on changedetection-io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4c3j-3h7v-22q9 (OSV record GHSA-4c3j-3h7v-22q9 lists affected ranges: PyPI changedetection-io >=0 <0.50.34 (fixed))
- Verified: https://github.com/advisories/GHSA-4c3j-3h7v-22q9 (GitHub-reviewed advisory GHSA-4c3j-3h7v-22q9 lists affected ranges: PyPI changedetection-io >=0 <0.50.34)

Commands are suggestions: review each one before running it.

Loading voting…