n8n Vulnerable to Remote Code Execution via Git Node Pre-Commit Hook
CVE-2025-62726GHSA-xgp7-7qjq-vg47
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.113.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.113.0
- Fixed in
- 1.113.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xgp7-7qjq-vg47 lists affected ranges: npm n8n >=0 <1.113.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xgp7-7qjq-vg47 lists affected ranges: npm n8n >=0 <1.113.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-62726: 0.81% estimated exploitation activity in the next 30 days; percentile 57.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A remote code execution vulnerability exists in the Git Node component available in both Cloud and Self-Hosted versions of n8n. When a malicious actor clones a remote repository containing a pre-commit hook, the subsequent use of the Commit operation in the Git Node can inadvertently trigger the hook’s execution. This allows attackers to execute arbitrary code within the n8n environment, potentially compromising the system and any connected credentials or workflows. All users with workflows that utilize the Git Node to clone untrusted repositories are affected. Patches The vulnerability was addressed in v1.113.0 (n8n-io/n8n#19559), which introduces a new environment variable: N8NGITNODEDISABLEBAREREPOS. For self-hosted deployments, it is strongly recommended to set this variable to true to mitigate the risk of executing malicious Git hooks. Workarounds To reduce risk prior to upgrading: - Avoid cloning or interacting with untrusted repositories using the Git Node. - Disable or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xgp7-7qjq-vg47
- Revision 1 · created ·
Published from osv record GHSA-xgp7-7qjq-vg47
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62726 Advisory: n8n Vulnerable to Remote Code Execution via Git Node Pre-Commit Hook IDs: CVE-2025-62726, GHSA-xgp7-7qjq-vg47 Record: https://patchnext.com/advisories/cve-2025-62726 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 1.113.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.113.0; fixed in 1.113.0 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xgp7-7qjq-vg47 (OSV record GHSA-xgp7-7qjq-vg47 lists affected ranges: npm n8n >=0 <1.113.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xgp7-7qjq-vg47 (GitHub-reviewed advisory GHSA-xgp7-7qjq-vg47 lists affected ranges: npm n8n >=0 <1.113.0) Commands are suggestions: review each one before running it.
Loading voting…