Kottster app reinitialization can be re-triggered allowing command injection in development mode
CVE-2025-62713GHSA-j3w7-9qc3-g96p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@kottster/server 3.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @kottster/server
- Affected
- >= 3.2.0, < 3.3.2
- Fixed in
- 3.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j3w7-9qc3-g96p lists affected ranges: npm @kottster/server >=3.2.0 <3.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3w7-9qc3-g96p lists affected ranges: npm @kottster/server >=3.2.0 <3.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-62713: 0.61% estimated exploitation activity in the next 30 days; percentile 49.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Development mode only. Kottster contains a pre-authentication remote code execution (RCE) vulnerability when running in development mode. The vulnerability combines two issues: 1. The initApp action can be called repeatedly without checking if the app is already initialized, allowing attackers to create a new root admin account and obtain a JWT token 2. The installPackagesForDataSource action uses unescaped command arguments, enabling command injection An attacker with access to a locally running development instance can chain these vulnerabilities to: - Reinitialize the application and receive a JWT token for a new root account - Use this token to authenticate - Execute arbitrary system commands through installPackagesForDataSource Production deployments were never affected. Patches Fixed in v3.3.2. Specifically, @kottster/server v3.3.2 and @kottster/cli v3.3.2 address this vulnerability. We recommend developers using earlier versions of @kottster/server and @kottster/cli…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j3w7-9qc3-g96p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-j3w7-9qc3-g96p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62713 Advisory: Kottster app reinitialization can be re-triggered allowing command injection in development mode IDs: CVE-2025-62713, GHSA-j3w7-9qc3-g96p Record: https://patchnext.com/advisories/cve-2025-62713 (revision 3, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @kottster/server 3.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @kottster/server: affected >= 3.2.0, < 3.3.2; fixed in 3.3.2 ## Suggested inspection (read-only) - `npm ls @kottster/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @kottster/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j3w7-9qc3-g96p (OSV record GHSA-j3w7-9qc3-g96p lists affected ranges: npm @kottster/server >=3.2.0 <3.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-j3w7-9qc3-g96p (GitHub-reviewed advisory GHSA-j3w7-9qc3-g96p lists affected ranges: npm @kottster/server >=3.2.0 <3.3.2) Commands are suggestions: review each one before running it.
Loading voting…