Skip to content

← Actionable
Medium, CVSS 6.5amended

Authlib : JWE zip=DEF decompression bomb enables DoS

CVE-2025-62706GHSA-g7f3-828f-7h7m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.6.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI authlib

    Affected
    < 1.6.5
    Fixed in
    1.6.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-62706: 0.46% estimated exploitation activity in the next 30 days; percentile 39.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Authlib’s JWE zip=DEF path performs unbounded DEFLATE decompression. A very small ciphertext can expand into tens or hundreds of megabytes on decrypt, allowing an attacker who can supply decryptable tokens to exhaust memory and CPU and cause denial of service. Details - Affected component: Authlib JOSE, JWE zip=DEF (DEFLATE) support. - In authlib/authlib/jose/rfc7518/jwezips.py, DeflateZipAlgorithm.decompress calls zlib.decompress(s, -zlib.MAXWBITS) without a maximum output limit. This permits unbounded expansion of compressed payloads. - In the JWE decode flow (authlib/authlib/jose/rfc7516/jwe.py), when the protected header contains "zip": "DEF", the library routes the decrypted ciphertext into the decompress method and assigns the fully decompressed bytes to the plaintext field before returning it. No streaming limit or quota is applied. - Because DEFLATE achieves extremely high ratios on highly repetitive input, an attacker can craft a tiny zip=DEF ciphertext that inflates…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g7f3-828f-7h7m

  2. Revision 1 · created ·

    Published from osv record GHSA-g7f3-828f-7h7m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62706

Advisory: Authlib : JWE zip=DEF decompression bomb enables DoS
IDs: CVE-2025-62706, GHSA-g7f3-828f-7h7m
Record: https://patchnext.com/advisories/cve-2025-62706 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: authlib 1.6.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI authlib: affected < 1.6.5; fixed in 1.6.5

## Suggested inspection (read-only)
- `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on authlib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g7f3-828f-7h7m (OSV record GHSA-g7f3-828f-7h7m lists affected ranges: PyPI authlib >=0 <1.6.5 (fixed))
- Verified: https://github.com/advisories/GHSA-g7f3-828f-7h7m (GitHub-reviewed advisory GHSA-g7f3-828f-7h7m lists affected ranges: PyPI authlib >=0 <1.6.5)

Commands are suggestions: review each one before running it.

Loading voting…