Velociraptor vulnerable to privilege escalation via UpdateConfig artifact
CVE-2025-6264GHSA-gpfc-mph4-qm24
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (www.velocidex.com/golang/velociraptor 0.74.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go www.velocidex.com/golang/velociraptor
- Affected
- < 0.74.3
- Fixed in
- 0.74.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gpfc-mph4-qm24 lists affected ranges: Go www.velocidex.com/golang/velociraptor >=0 <0.74.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.7 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2025-6264: 1.03% estimated exploitation activity in the next 30 days; percentile 63.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Velociraptor allows collection of VQL queries packaged into Artifacts from endpoints. These artifacts can be used to do anything and usually run with elevated permissions. To limit access to some dangerous artifact, Velociraptor allows for those to require high permissions like EXECVE to launch. The Admin.Client.UpdateClientConfig is an artifact used to update the client's configuration. This artifact did not enforce an additional required permission, allowing users with COLLECTCLIENT permissions (normally given by the "Investigator" role) to collect it from endpoints and update the configuration. This can lead to arbitrary command execution and endpoint takeover. To successfully exploit this vulnerability the user must already have access to collect artifacts from the endpoint (i.e. have the COLLECTCLIENT given typically by the "Investigator' role).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gpfc-mph4-qm24
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-6264 Advisory: Velociraptor vulnerable to privilege escalation via UpdateConfig artifact IDs: CVE-2025-6264, GHSA-gpfc-mph4-qm24 Record: https://patchnext.com/advisories/cve-2025-6264 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: www.velocidex.com/golang/velociraptor 0.74.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go www.velocidex.com/golang/velociraptor: affected < 0.74.3; fixed in 0.74.3 ## Suggested inspection (read-only) - Go www.velocidex.com/golang/velociraptor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on www.velocidex.com/golang/velociraptor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gpfc-mph4-qm24 (GitHub-reviewed advisory GHSA-gpfc-mph4-qm24 lists affected ranges: Go www.velocidex.com/golang/velociraptor >=0 <0.74.3) Commands are suggestions: review each one before running it.
Loading voting…