Skip to content

← Actionable
High, CVSS 7.2

Admidio Vulnerable to Authenticated SQL Injection in Member Assignment Functionality

CVE-2025-62617GHSA-2v5m-cq9w-fc33

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (admidio/admidio 4.3.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-62617: 0.43% estimated exploitation activity in the next 30 days; percentile 37.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An authenticated SQL injection vulnerability exists in the member assignment data retrieval functionality of Admidio. Any authenticated user with permissions to assign members to a role (such as an administrator) can exploit this vulnerability to execute arbitrary SQL commands. This can lead to a full compromise of the application's database, including reading, modifying, or deleting all data. The vulnerability is present in the latest version, 4.3.16. Details The vulnerability is located in the admprogram/modules/groups-roles/membersassignmentdata.php script. This script handles an AJAX request to fetch a list of users for role assignment. The filterroluuid GET parameter is not properly sanitized before being used in a raw SQL query. File: admprogram/modules/groups-roles/membersassignmentdata.php As shown above, the value of $getFilterRoleUuid is directly concatenated into the $filterRoleCondition variable, which is then embedded within a larger SQL query ($sqlSubSelect).…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2v5m-cq9w-fc33

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62617

Advisory: Admidio Vulnerable to Authenticated SQL Injection in Member Assignment Functionality
IDs: CVE-2025-62617, GHSA-2v5m-cq9w-fc33
Record: https://patchnext.com/advisories/cve-2025-62617 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: admidio/admidio 4.3.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist admidio/admidio: affected <= 4.3.16; fixed in 4.3.17

## Suggested inspection (read-only)
- Packagist admidio/admidio: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on admidio/admidio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2v5m-cq9w-fc33 (GitHub-reviewed advisory GHSA-2v5m-cq9w-fc33 lists affected ranges: Packagist admidio/admidio >=0 <=4.3.16)

Commands are suggestions: review each one before running it.

Loading voting…