Skip to content

← Actionable
High, CVSS 8.2amended

aiomysql allows arbitrary access to client files through vulnerability of a malicious MySQL server

CVE-2025-62611GHSA-r397-ff8c-wv2g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aiomysql 0.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aiomysql

    Affected
    <= 0.2.0
    Fixed in
    0.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-62611: 0.39% estimated exploitation activity in the next 30 days; percentile 33.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The client-side settings are not checked before sending local files to MySQL server, which allows obtaining arbitrary files from the client using a rogue server. Details It is possible to create a rogue MySQL server that emulates authorization, ignores client flags and requests arbitrary files from the client by sending a LOADLOCAL instruction packet. Related to CVE-2019-2503. PoC First, start up a rogue MySQL server that ignores client-side flags and sends LOADLOCAL packet to the client – tested with https://github.com/rmb122/roguemysqlserver 1. Create a file to be stolen by the rogue server: echo "gotcha" /tmp/mysecretfile.txt 2. Clone the repo: git clone git@github.com:rmb122/roguemysqlserver.git && cd roguemysqlserver 3. Build the server: make roguemysqlserver 4. Generate a sample config: roguemysqlserver -generate 5. In config.yaml change filelist to ["/tmp/mysecretfile.txt"] 6. Run the server: ./roguemysqlserver -config config.yaml Next, the vulnerability can be seen in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r397-ff8c-wv2g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r397-ff8c-wv2g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62611

Advisory: aiomysql allows arbitrary access to client files through vulnerability of a malicious MySQL server
IDs: CVE-2025-62611, GHSA-r397-ff8c-wv2g
Record: https://patchnext.com/advisories/cve-2025-62611 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aiomysql 0.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aiomysql: affected <= 0.2.0; fixed in 0.3.0

## Suggested inspection (read-only)
- `python -m pip show aiomysql`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aiomysql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r397-ff8c-wv2g (OSV record GHSA-r397-ff8c-wv2g lists affected ranges: PyPI aiomysql >=0 <0.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-r397-ff8c-wv2g (GitHub-reviewed advisory GHSA-r397-ff8c-wv2g lists affected ranges: PyPI aiomysql >=0 <=0.2.0)

Commands are suggestions: review each one before running it.

Loading voting…