Skip to content

← Actionable
Medium, CVSS 5.5amended

MLX has Wild Pointer Dereference in load_gguf()

CVE-2025-62609GHSA-j842-xgm4-wf88

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlx 0.29.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mlx

    Affected
    <= 0.29.3
    Fixed in
    0.29.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-62609: 0.40% estimated exploitation activity in the next 30 days; percentile 34.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Segmentation fault in mlx::core::loadgguf() when loading malicious GGUF files. Untrusted pointer from external gguflib library is dereferenced without validation, causing application crash. Environment: - OS: Ubuntu 20.04.6 LTS - Compiler: Clang 19.1.7 Vulnerability Location: mlx/io/gguf.cpp - Function extracttensordata() at lines 59-79 - Vulnerable memcpy at lines 64-67 - Called from loadarrays() at line 177 The Bug: Possible Fix PoC Download the poc file there, or let me know how I can send it to you. AddressSanitizer Output (with instrumented build): Impact - Attack vector: Malicious GGUF file (model weights, typically from untrusted sources) - Affects: MLX users on all platforms who call the vulnerable method with unsanitized input. - Result: Segmentation fault (uncatchable by exception handlers) --- Credits: - Markiyan Melnyk (ARIMLABS) - Mykyta Mudryi (ARIMLABS) - Markiyan Chaklosh (ARIMLABS)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j842-xgm4-wf88

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-j842-xgm4-wf88

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62609

Advisory: MLX has Wild Pointer Dereference in load_gguf()
IDs: CVE-2025-62609, GHSA-j842-xgm4-wf88
Record: https://patchnext.com/advisories/cve-2025-62609 (revision 3, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mlx 0.29.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mlx: affected <= 0.29.3; fixed in 0.29.4

## Suggested inspection (read-only)
- `python -m pip show mlx`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mlx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j842-xgm4-wf88 (OSV record GHSA-j842-xgm4-wf88 lists affected ranges: PyPI mlx >=0 <0.29.4 (fixed))
- Verified: https://github.com/advisories/GHSA-j842-xgm4-wf88 (GitHub-reviewed advisory GHSA-j842-xgm4-wf88 lists affected ranges: PyPI mlx >=0 <=0.29.3)

Commands are suggestions: review each one before running it.

Loading voting…