Skip to content

← Actionable
Medium, CVSS 5.5amended

MLX has heap-buffer-overflow in load()

CVE-2025-62608GHSA-w6vg-jg77-2qg6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlx 0.29.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mlx

    Affected
    <= 0.29.3
    Fixed in
    0.29.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-62608: 0.56% estimated exploitation activity in the next 30 days; percentile 46.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Heap buffer overflow in mlx::core::load() when parsing malicious NumPy .npy files. Attacker-controlled file causes 13-byte out-of-bounds read, leading to crash or information disclosure. Environment: - OS: Ubuntu 20.04.6 LTS - Compiler: Clang 19.1.7 Vulnerability The parser reads a 118-byte header from the file, but line 268 uses std::string(&buffer[0]) which stops at the first null byte, creating a 20-byte string instead. Then line 276 tries to read header[34] without checking the length first, reading 13 bytes past the allocation. Location: mlx/io/load.cpp:268,276 Bug #1 (line 268): Bug #2 (line 276): Possible Fix PoC AddressSanitizer Output (with instrumented build): Impact - Attack vector: Malicious .npy file (model weights, datasets, checkpoints) - Affects: MLX users on all platforms who call the vulnerable methods with unsanitized input. - Result: Application crash + potential 13-byte heap leak --- Credits: - Markiyan Melnyk (ARIMLABS) - Mykyta Mudryi (ARIMLABS) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w6vg-jg77-2qg6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-w6vg-jg77-2qg6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62608

Advisory: MLX has heap-buffer-overflow in load()
IDs: CVE-2025-62608, GHSA-w6vg-jg77-2qg6
Record: https://patchnext.com/advisories/cve-2025-62608 (revision 3, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mlx 0.29.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mlx: affected <= 0.29.3; fixed in 0.29.4

## Suggested inspection (read-only)
- `python -m pip show mlx`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mlx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w6vg-jg77-2qg6 (OSV record GHSA-w6vg-jg77-2qg6 lists affected ranges: PyPI mlx >=0 <0.29.4 (fixed))
- Verified: https://github.com/advisories/GHSA-w6vg-jg77-2qg6 (GitHub-reviewed advisory GHSA-w6vg-jg77-2qg6 lists affected ranges: PyPI mlx >=0 <=0.29.3)

Commands are suggestions: review each one before running it.

Loading voting…