Koa Vulnerable to Open Redirect via Trailing Double-Slash (//) in back Redirect Logic
CVE-2025-62595GHSA-g8mr-fgfg-5qpc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (koa 3.0.3, 2.16.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm koa
- Affected
- >= 3.0.1, < 3.0.3>= 2.16.2, < 2.16.3
- Fixed in
- 2.16.3, 3.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g8mr-fgfg-5qpc lists affected ranges: npm koa >=3.0.1 =2.16.2 <2.16.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g8mr-fgfg-5qpc lists affected ranges: npm koa >=3.0.1 =2.16.2 <2.16.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.7 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N
- EPSS
- CVE-2025-62595: 0.29% estimated exploitation activity in the next 30 days; percentile 21.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary: A bypass was discovered in the Koa.js framework affecting its back redirect functionality. In certain circumstances, an attacker can manipulate the Referer header to force a user’s browser to navigate to an external, potentially malicious website. This occurs because the implementation incorrectly treats some specially crafted URLs as safe relative paths. Exploiting this vulnerability could allow attackers to perform phishing, social engineering, or other redirect-based attacks on users of affected applications. This vulnerability affects the code referenced in GitHub Advisory GHSA-jgmv-j7ww-jx2x (which is tracked as CVE‑2025‑54420). Details: The patched code attempts to treat values that startWith('/') as safe relative paths and only perform origin checks for absolute URLs. However, protocol‑relative URLs (those beginning with //host) also start with '/' and therefore match the startsWith('/') branch. A protocol‑relative referrer such as //evil.com with trailing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g8mr-fgfg-5qpc
- Revision 1 · created ·
Published from osv record GHSA-g8mr-fgfg-5qpc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62595 Advisory: Koa Vulnerable to Open Redirect via Trailing Double-Slash (//) in back Redirect Logic IDs: CVE-2025-62595, GHSA-g8mr-fgfg-5qpc Record: https://patchnext.com/advisories/cve-2025-62595 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: koa 3.0.3, 2.16.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm koa: affected >= 3.0.1, < 3.0.3; >= 2.16.2, < 2.16.3; fixed in 2.16.3, 3.0.3 ## Suggested inspection (read-only) - `npm ls koa --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on koa. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g8mr-fgfg-5qpc (OSV record GHSA-g8mr-fgfg-5qpc lists affected ranges: npm koa >=3.0.1 =2.16.2 <2.16.3 (fixed)) - Verified: https://github.com/advisories/GHSA-g8mr-fgfg-5qpc (GitHub-reviewed advisory GHSA-g8mr-fgfg-5qpc lists affected ranges: npm koa >=3.0.1 =2.16.2 <2.16.3) Commands are suggestions: review each one before running it.
Loading voting…