Skip to content

← Actionable
Critical, CVSS 9.4Exploited · CISA KEVamended

Ray is vulnerable to Critical RCE via Safari & Firefox Browsers through DNS Rebinding Attack

CVE-2025-62593GHSA-q279-jhrf-cc6v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ray 2.52.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ray

    Affected
    < 2.52.0
    Fixed in
    2.52.0

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-62593: 60.15% estimated exploitation activity in the next 30 days; percentile 99.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Developers working with Ray as a development tool can be exploited via a critical RCE vulnerability exploitable via Firefox and Safari. Due to the longstanding decision by the Ray Development team to not implement any sort of authentication on critical endpoints, like the /api/jobs & /api/jobagent/jobs/ has once again led to a severe vulnerability that allows attackers to execute arbitrary code against Ray. This time in a development context via the browsers Firefox and Safari. This vulnerability is due to an insufficient guard against browser-based attacks, as the current defense uses the User-Agent header starting with the string "Mozilla" as a defense mechanism. This defense is insufficient as the fetch specification allows the User-Agent header to be modified. Combined with a DNS rebinding attack against the browser, and this vulnerability is exploitable against a developer running Ray who inadvertently visits a malicious website, or is served a malicious advertisement…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-q279-jhrf-cc6v

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-q279-jhrf-cc6v

  4. Revision 1 · created ·

    Published from ghsa record GHSA-q279-jhrf-cc6v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62593

Advisory: Ray is vulnerable to Critical RCE via Safari & Firefox Browsers through DNS Rebinding Attack
IDs: CVE-2025-62593, GHSA-q279-jhrf-cc6v
Record: https://patchnext.com/advisories/cve-2025-62593 (revision 4, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: ray 2.52.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ray: affected < 2.52.0; fixed in 2.52.0

## Suggested inspection (read-only)
- `python -m pip show ray`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ray.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-62593 to the Known Exploited Vulnerabilities catalog on 2026-08-17.)
- Verified: https://github.com/advisories/GHSA-q279-jhrf-cc6v (GitHub-reviewed advisory GHSA-q279-jhrf-cc6v lists affected ranges: PyPI ray >=0 <2.52.0)
- Verified: https://osv.dev/vulnerability/GHSA-q279-jhrf-cc6v (OSV record GHSA-q279-jhrf-cc6v lists affected ranges: PyPI ray >=0 <2.52.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…