Taguette password reset link poisoning
CVE-2025-62527GHSA-7rc8-5c8q-jr6j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (taguette 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI taguette
- Affected
- < 1.5.0
- Fixed in
- 1.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7rc8-5c8q-jr6j lists affected ranges: PyPI taguette >=0 <1.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7rc8-5c8q-jr6j lists affected ranges: PyPI taguette >=0 <1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- EPSS
- CVE-2025-62527: 0.25% estimated exploitation activity in the next 30 days; percentile 16.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An issue has been discovered in Taguette versions prior to 1.5.0. It was possible for an attacker to request password reset email containing a malicious link, allowing the attacker to set the email if clicked by the victim. Patches Users should upgrade to Taguette 1.5.0. References - https://gitlab.com/remram44/taguette/-/issues/331
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7rc8-5c8q-jr6j
- Revision 1 · created ·
Published from osv record GHSA-7rc8-5c8q-jr6j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62527 Advisory: Taguette password reset link poisoning IDs: CVE-2025-62527, GHSA-7rc8-5c8q-jr6j Record: https://patchnext.com/advisories/cve-2025-62527 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: taguette 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI taguette: affected < 1.5.0; fixed in 1.5.0 ## Suggested inspection (read-only) - `python -m pip show taguette`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on taguette. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7rc8-5c8q-jr6j (OSV record GHSA-7rc8-5c8q-jr6j lists affected ranges: PyPI taguette >=0 <1.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7rc8-5c8q-jr6j (GitHub-reviewed advisory GHSA-7rc8-5c8q-jr6j lists affected ranges: PyPI taguette >=0 <1.5.0) Commands are suggestions: review each one before running it.
Loading voting…