vite allows server.fs.deny bypass via backslash on Windows
CVE-2025-62522GHSA-93m4-6634-74q7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 7.1.11, 7.0.8, 6.4.1, 5.4.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vite
- Affected
- >= 7.1.0, < 7.1.11>= 7.0.0, < 7.0.8>= 6.0.0, < 6.4.1>= 2.9.18, < 5.4.21>= 3.2.9, < 5.4.21>= 4.5.3, < 5.4.21>= 5.2.6, < 5.4.21
- Fixed in
- 7.1.11, 7.0.8, 6.4.1, 5.4.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-93m4-6634-74q7 lists affected ranges: npm vite >=7.1.0 =7.0.0 =6.0.0 =2.9.18 =3.2.9 =4.5.3 =5.2.6 <5.4.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-62522: 1.05% estimated exploitation activity in the next 30 days; percentile 64.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Files denied by `server.fs.deny` were sent if the URL ended with `\` when the dev server is running on Windows.
Impact Only apps that match the following conditions are affected: - explicitly exposes the Vite dev server to the network (using --host or `server.host` config option) - running the dev server on Windows
Details `server.fs.deny` can contain patterns matching against files (by default it includes `.env`, `.env.*`, `*.{crt,pem}` as such patterns). These patterns were able to bypass by using a back slash(`\`). The root cause is that `fs.readFile('/foo.png/')` loads `/foo.png`.
PoC ```shell npm create vite@latest cd vite-project/ cat "secret" > .env npm install npm run dev curl --request-target /.env\ http://localhost:5173 ```
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-93m4-6634-74q7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62522 Advisory: vite allows server.fs.deny bypass via backslash on Windows IDs: CVE-2025-62522, GHSA-93m4-6634-74q7 Record: https://patchnext.com/advisories/cve-2025-62522 (revision 2, source checked 24 Oct 2026, 22:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vite 7.1.11, 7.0.8, 6.4.1, 5.4.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vite: affected >= 7.1.0, < 7.1.11; >= 7.0.0, < 7.0.8; >= 6.0.0, < 6.4.1; >= 2.9.18, < 5.4.21; >= 3.2.9, < 5.4.21; >= 4.5.3, < 5.4.21; >= 5.2.6, < 5.4.21; fixed in 7.1.11, 7.0.8, 6.4.1, 5.4.21 ## Suggested inspection (read-only) - `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vite. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-93m4-6634-74q7 (OSV record GHSA-93m4-6634-74q7 lists affected ranges: npm vite >=7.1.0 =7.0.0 =6.0.0 =2.9.18 =3.2.9 =4.5.3 =5.2.6 <5.4.21 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…