phpMyFAQ has Authenticated SQL Injection in Configuration Update Functionality
CVE-2025-62519GHSA-fxm2-cmwj-qvx4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyfaq/phpmyfaq 4.0.14; thorsten/phpmyfaq 4.0.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyfaq/phpmyfaq
- Affected
- <= 4.0.13
- Fixed in
- 4.0.14
Packagist thorsten/phpmyfaq
- Affected
- <= 4.0.13
- Fixed in
- 4.0.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fxm2-cmwj-qvx4 lists affected ranges: Packagist thorsten/phpmyfaq >=0 =0 <=4.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-62519: 0.80% estimated exploitation activity in the next 30 days; percentile 56.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authenticated SQL injection vulnerability in the main configuration update functionality of phpMyFAQ (v4.0.13 and prior) allows a privileged user with 'Configuration Edit' permissions to execute arbitrary SQL commands. Successful exploitation can lead to a full compromise of the database, including reading, modifying, or deleting all data, as well as potential remote code execution depending on the database configuration. Details The vulnerability exists in the save method within the src/phpMyFAQ/Controller/Administration/ConfigurationTabController.php controller. This method handles the saving of application-wide configuration settings. It retrieves all submitted form data as an associative array via $request-get('edit'). The core of the issue is that while the values of this array are processed, the keys are trusted implicitly and are not sanitized or validated. File: src/phpMyFAQ/Controller/Administration/ConfigurationTabController.php The $newConfigValues array, which…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fxm2-cmwj-qvx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62519 Advisory: phpMyFAQ has Authenticated SQL Injection in Configuration Update Functionality IDs: CVE-2025-62519, GHSA-fxm2-cmwj-qvx4 Record: https://patchnext.com/advisories/cve-2025-62519 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyfaq/phpmyfaq 4.0.14; thorsten/phpmyfaq 4.0.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyfaq/phpmyfaq: affected <= 4.0.13; fixed in 4.0.14 - Packagist thorsten/phpmyfaq: affected <= 4.0.13; fixed in 4.0.14 ## Suggested inspection (read-only) - Packagist phpmyfaq/phpmyfaq: check the installed version with your package manager. - Packagist thorsten/phpmyfaq: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyfaq/phpmyfaq, thorsten/phpmyfaq. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fxm2-cmwj-qvx4 (GitHub-reviewed advisory GHSA-fxm2-cmwj-qvx4 lists affected ranges: Packagist thorsten/phpmyfaq >=0 =0 <=4.0.13) Commands are suggestions: review each one before running it.
Loading voting…