rollbar vulnerable to Prototype Pollution in merge()
CVE-2025-62517GHSA-xcg2-9pp4-j82x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rollbar 3.0.0-beta5, 2.26.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm rollbar
- Affected
- <= 2.26.4>= 3.0.0-alpha1, <= 3.0.0-beta4
- Fixed in
- 3.0.0-beta5, 2.26.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xcg2-9pp4-j82x lists affected ranges: npm rollbar >=0 =3.0.0-alpha1 <3.0.0-beta5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xcg2-9pp4-j82x lists affected ranges: npm rollbar >=0 =3.0.0-alpha1 <=3.0.0-beta4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2025-62517: 0.39% estimated exploitation activity in the next 30 days; percentile 33.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Prototype pollution vulnerability in merge(). If application code calls rollbar.configure() with untrusted input, prototype pollution is possible. Patches Fixed in 2.26.5 and 3.0.0-beta5. Workarounds Ensure that values passed to rollbar.configure() do not contain untrusted input. References Fixed in https://github.com/rollbar/rollbar.js/pull/1394 (2.26.x) and https://github.com/rollbar/rollbar.js/pull/1390 (3.x)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xcg2-9pp4-j82x
- Revision 1 · created ·
Published from osv record GHSA-xcg2-9pp4-j82x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62517 Advisory: rollbar vulnerable to Prototype Pollution in merge() IDs: CVE-2025-62517, GHSA-xcg2-9pp4-j82x Record: https://patchnext.com/advisories/cve-2025-62517 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rollbar 3.0.0-beta5, 2.26.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm rollbar: affected <= 2.26.4; >= 3.0.0-alpha1, <= 3.0.0-beta4; fixed in 3.0.0-beta5, 2.26.5 ## Suggested inspection (read-only) - `npm ls rollbar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rollbar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xcg2-9pp4-j82x (OSV record GHSA-xcg2-9pp4-j82x lists affected ranges: npm rollbar >=0 =3.0.0-alpha1 <3.0.0-beta5 (fixed)) - Verified: https://github.com/advisories/GHSA-xcg2-9pp4-j82x (GitHub-reviewed advisory GHSA-xcg2-9pp4-j82x lists affected ranges: npm rollbar >=0 =3.0.0-alpha1 <=3.0.0-beta4) Commands are suggestions: review each one before running it.
Loading voting…