Skip to content

← Actionable
Medium, CVSS 5.7

OpenBao leaks HTTPRawBody in Audit Logs

CVE-2025-62513GHSA-ghfh-fmx4-26h8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openbao/openbao 0.0.0-20251022165510-cc2c476bac66), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/openbao/openbao

    Affected
    >= 0.0.0-20241114205727-b1235e585db7, < 0.0.0-20251022165510-cc2c476bac66
    Fixed in
    0.0.0-20251022165510-cc2c476bac66

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-ghfh-fmx4-26h8 lists affected ranges: Go github.com/openbao/openbao >=0.0.0-20241114205727-b1235e585db7 <0.0.0-20251022165510-cc2c476bac66

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-62513: 0.32% estimated exploitation activity in the next 30 days; percentile 24.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact OpenBao's audit log experienced a regression wherein raw HTTP bodies used by few endpoints were not correctly redacted (HMAC'd). This impacted the following subsystems: - When using the ACME functionality of PKI, this would result in short-lived ACME verification challenge codes being leaked in the audit logs. - When using the OIDC issuer functionality of the identity subsystem, auth and token response codes along with claims could be leaked in the audit logs. Third-party plugins may be affected. Patches OpenBao v2.4.2 will patch this issue. Workarounds If users do not use the above functionality, they are not impacted. ACME verification codes are not usable after verification or challenge expiry so are of limited long-term use.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ghfh-fmx4-26h8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62513

Advisory: OpenBao leaks HTTPRawBody in Audit Logs
IDs: CVE-2025-62513, GHSA-ghfh-fmx4-26h8
Record: https://patchnext.com/advisories/cve-2025-62513 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/openbao/openbao 0.0.0-20251022165510-cc2c476bac66. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/openbao/openbao: affected >= 0.0.0-20241114205727-b1235e585db7, < 0.0.0-20251022165510-cc2c476bac66; fixed in 0.0.0-20251022165510-cc2c476bac66

## Suggested inspection (read-only)
- Go github.com/openbao/openbao: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/openbao/openbao.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ghfh-fmx4-26h8 (GitHub-reviewed advisory GHSA-ghfh-fmx4-26h8 lists affected ranges: Go github.com/openbao/openbao >=0.0.0-20241114205727-b1235e585db7 <0.0.0-20251022165510-cc2c476bac66)

Commands are suggestions: review each one before running it.

Loading voting…