Angular SSR has a Server-Side Request Forgery (SSRF) flaw
CVE-2025-62427GHSA-q63q-pgmf-mxhr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@angular/ssr 21.0.0-next.8, 20.3.6, 19.2.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @angular/ssr
- Affected
- >= 19.0.0-next.0, < 19.2.18>= 20.0.0-next.0, < 20.3.6>= 21.0.0-next.0, < 21.0.0-next.8
- Fixed in
- 20.3.6, 21.0.0-next.8, 19.2.18
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q63q-pgmf-mxhr lists affected ranges: npm @angular/ssr >=19.0.0-next.0 =20.0.0-next.0 =21.0.0-next.0 <21.0.0-next.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q63q-pgmf-mxhr lists affected ranges: npm @angular/ssr >=19.0.0-next.0 =20.0.0-next.0 =21.0.0-next.0 <21.0.0-next.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-62427: 0.43% estimated exploitation activity in the next 30 days; percentile 37.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The vulnerability is a Server-Side Request Forgery (SSRF) flaw within the URL resolution mechanism of Angular's Server-Side Rendering package (@angular/ssr). The function createRequestUrl uses the native URL constructor. When an incoming request path (e.g., originalUrl or url) begins with a double forward slash (//) or backslash (\\), the URL constructor treats it as a schema-relative URL. This behavior overrides the security-intended base URL (protocol, host, and port) supplied as the second argument, instead resolving the URL against the scheme of the base URL but adopting the attacker-controlled hostname. This allows an attacker to specify an external domain in the URL path, tricking the Angular SSR environment into setting the page's virtual location (accessible via DOCUMENT or PlatformLocation tokens) to this attacker-controlled domain. Any subsequent relative HTTP requests made during the SSR process (e.g., using HttpClient.get('assets/data.json')) will be incorrectly…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q63q-pgmf-mxhr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q63q-pgmf-mxhr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62427 Advisory: Angular SSR has a Server-Side Request Forgery (SSRF) flaw IDs: CVE-2025-62427, GHSA-q63q-pgmf-mxhr Record: https://patchnext.com/advisories/cve-2025-62427 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @angular/ssr 21.0.0-next.8, 20.3.6, 19.2.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/ssr: affected >= 19.0.0-next.0, < 19.2.18; >= 20.0.0-next.0, < 20.3.6; >= 21.0.0-next.0, < 21.0.0-next.8; fixed in 20.3.6, 21.0.0-next.8, 19.2.18 ## Suggested inspection (read-only) - `npm ls @angular/ssr --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/ssr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q63q-pgmf-mxhr (OSV record GHSA-q63q-pgmf-mxhr lists affected ranges: npm @angular/ssr >=19.0.0-next.0 =20.0.0-next.0 =21.0.0-next.0 <21.0.0-next.8 (fixed)) - Verified: https://github.com/advisories/GHSA-q63q-pgmf-mxhr (GitHub-reviewed advisory GHSA-q63q-pgmf-mxhr lists affected ranges: npm @angular/ssr >=19.0.0-next.0 =20.0.0-next.0 =21.0.0-next.0 <21.0.0-next.8) Commands are suggestions: review each one before running it.
Loading voting…