vLLM is vulnerable to Server-Side Request Forgery (SSRF) through MediaConnector class
CVE-2025-6242GHSA-3f6c-7fw2-ppm4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.5.0, < 0.11.0
- Fixed in
- 0.11.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3f6c-7fw2-ppm4 lists affected ranges: PyPI vllm >=0.5.0 <0.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3f6c-7fw2-ppm4 lists affected ranges: PyPI vllm >=0.5.0 <0.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:H
- EPSS
- CVE-2025-6242: 0.25% estimated exploitation activity in the next 30 days; percentile 16.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Server-Side Request Forgery (SSRF) vulnerability exists in the MediaConnector class within the vLLM project's multimodal feature set. The loadfromurl and loadfromurlasync methods fetch and process media from user-provided URLs without adequate restrictions on the target hosts. This allows an attacker to coerce the vLLM server into making arbitrary requests to internal network resources. This vulnerability is particularly critical in containerized environments like llm-d, where a compromised vLLM pod could be used to scan the internal network, interact with other pods, and potentially cause denial of service or access sensitive data. For example, an attacker could make the vLLM pod send malicious requests to an internal llm-d management endpoint, leading to system instability by falsely reporting metrics like the KV cache state. Vulnerability Details The core of the vulnerability lies in the MediaConnector.loadfromurl method and its asynchronous counterpart. These methods…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3f6c-7fw2-ppm4
- Revision 1 · created ·
Published from osv record GHSA-3f6c-7fw2-ppm4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-6242 Advisory: vLLM is vulnerable to Server-Side Request Forgery (SSRF) through `MediaConnector` class IDs: CVE-2025-6242, GHSA-3f6c-7fw2-ppm4 Record: https://patchnext.com/advisories/cve-2025-6242 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.5.0, < 0.11.0; fixed in 0.11.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3f6c-7fw2-ppm4 (OSV record GHSA-3f6c-7fw2-ppm4 lists affected ranges: PyPI vllm >=0.5.0 <0.11.0 (fixed)) - Verified: https://github.com/advisories/GHSA-3f6c-7fw2-ppm4 (GitHub-reviewed advisory GHSA-3f6c-7fw2-ppm4 lists affected ranges: PyPI vllm >=0.5.0 <0.11.0) Commands are suggestions: review each one before running it.
Loading voting…