Skip to content

← Actionable
Medium, CVSS 5.1

bagisto has Server Side Template Injection (SSTI) in Product Description

CVE-2025-62416GHSA-527q-4wqv-g9wj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bagisto/bagisto 2.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.1 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:L
EPSS
  • CVE-2025-62416: 0.40% estimated exploitation activity in the next 30 days; percentile 34.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Bagisto v2.3.7 is vulnerable to Server-Side Template Injection (SSTI) due to unsanitized user input being processed by the server-side templating engine when rendering product descriptions. This allows an attacker with product creation privileges to inject arbitrary template expressions that are evaluated by the backend — potentially leading to Remote Code Execution (RCE) on the server. Details In Bagisto, product descriptions are rendered through Laravel’s Blade templating engine in various front-end and admin views. The product description field is not sanitized or escaped before being passed to the view, which means user-supplied data can break out of the expected string context and execute arbitrary template code. PoC Create a product and enter the payload to the description. <img width="679" height="669" alt="image" src="https://github.com/user-attachments/assets/1e5dac3f-4043-4b31-98ed-f4346feb5477" / Preview the page, observed that the template expressions were…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-527q-4wqv-g9wj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62416

Advisory: bagisto has Server Side Template Injection (SSTI) in Product Description
IDs: CVE-2025-62416, GHSA-527q-4wqv-g9wj
Record: https://patchnext.com/advisories/cve-2025-62416 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bagisto/bagisto 2.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist bagisto/bagisto: affected <= 2.3.7; fixed in 2.3.8

## Suggested inspection (read-only)
- Packagist bagisto/bagisto: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bagisto/bagisto.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-527q-4wqv-g9wj (GitHub-reviewed advisory GHSA-527q-4wqv-g9wj lists affected ranges: Packagist bagisto/bagisto >=0 <=2.3.7)

Commands are suggestions: review each one before running it.

Loading voting…