Skip to content

← Actionable
Low, CVSS 3.8

LibreNMS alert-rules has a Cross-Site Scripting Vulnerability

CVE-2025-62412GHSA-6g2v-66ch-6xmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 25.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-62412: 0.28% estimated exploitation activity in the next 30 days; percentile 20.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Executive Summary Product: LibreNMS Vendor: LibreNMS Vulnerability Type: Cross-Site Scripting (XSS) CVSS Score: 4.3 (AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L) Affected Version: 25.8.0 (latest at time of discovery) POC File: Download POC Ticket: ZDI-CAN-28105: LibreNMS Alert Rules Cross-Site Scripting Vulnerability Vulnerability Details Description Trend Micro's Zero Day Initiative has identified a Cross-Site Scripting vulnerability in LibreNMS. The vulnerability exists in the Alert Rules functionality where the alert rule name is not properly sanitized, allowing injection of HTML code. Technical Details Version Tested: 25.8.0 Installer File: 25.8.0.tar.gz Download Link: https://github.com/librenms/librenms/archive/refs/tags/25.8.0.tar.gz Platform: N/A Attack Vector When browsing to Alerts Alert Rules page, a LibreNMS admin can add and manage alert rules. The alert rule name field is vulnerable to XSS attacks through improper sanitization. Root Cause Analysis Vulnerable Request When…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6g2v-66ch-6xmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62412

Advisory: LibreNMS alert-rules has a Cross-Site Scripting Vulnerability
IDs: CVE-2025-62412, GHSA-6g2v-66ch-6xmh
Record: https://patchnext.com/advisories/cve-2025-62412 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 25.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist librenms/librenms: affected <= 25.8.0; fixed in 25.10.0

## Suggested inspection (read-only)
- Packagist librenms/librenms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on librenms/librenms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6g2v-66ch-6xmh (GitHub-reviewed advisory GHSA-6g2v-66ch-6xmh lists affected ranges: Packagist librenms/librenms >=0 <=25.8.0)

Commands are suggestions: review each one before running it.

Loading voting…