LibreNMS has a Stored XSS vulnerability in its Alert Transport name field
CVE-2025-62411GHSA-frc6-pwgr-c28w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 25.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist librenms/librenms
- Affected
- < 25.10.0
- Fixed in
- 25.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-frc6-pwgr-c28w lists affected ranges: Packagist librenms/librenms >=0 <25.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2025-62411: 12.72% estimated exploitation activity in the next 30 days; percentile 96.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary LibreNMS <= 25.8.0 contains a Stored Cross-Site Scripting (XSS) vulnerability in the Alert Transports management functionality. When an administrator creates a new Alert Transport, the value of the Transport name field is stored and later rendered in the Transports column of the Alert Rules page without proper input validation or output encoding. This leads to arbitrary JavaScript execution in the admin’s browser. Details Injection point: Transport name field in /alert-transports. Execution point: Transports column in /alert-rules. Scope: Only administrators can create Alert Transports, and only administrators can view the affected Alert Rules page. Therefore, both exploitation and impact are limited to admin users. Steps to reproduce 1. Log in with an administrator account. 2. Navigate to: 3. Click Create alert transport and provide the following values: Transport name: Default Alert: ON Email: test@gmail.com (or any valid email) Save the transport. 4. Navigate to . A popup…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-frc6-pwgr-c28w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62411 Advisory: LibreNMS has a Stored XSS vulnerability in its Alert Transport name field IDs: CVE-2025-62411, GHSA-frc6-pwgr-c28w Record: https://patchnext.com/advisories/cve-2025-62411 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 25.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist librenms/librenms: affected < 25.10.0; fixed in 25.10.0 ## Suggested inspection (read-only) - Packagist librenms/librenms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on librenms/librenms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-frc6-pwgr-c28w (GitHub-reviewed advisory GHSA-frc6-pwgr-c28w lists affected ranges: Packagist librenms/librenms >=0 <25.10.0) Commands are suggestions: review each one before running it.
Loading voting…